Error uploading aab to play console about

I uploaded an aab with version (1), which was the wearos aab from watch face studio, i released it to internal testing and all was fine.
Then a half hour later i uploaded an aab (2) for a companion app from android studio and suddenly i get this error for aab (1) when including it in the next release. Same error occurs if i do new versions for both, or just the wear os aab on its own.
Anyone any ideas?



I’m having the same problem since yesterday. In my case I tried to upload an app (not watchface) along with a phone app, the same error shows up… I don’t know what to do… I did a quick search and found nothing about it

1 Like

I think i may have a temporary workaround: removing the wear os form factor in advanced settings, then readding it after creating the release.


I might be wrong, but checking more closely the “production” release screen (I dont know the name in english, my ui is in Portuguese), the screen where you have the button to create a new version, on the left side of the button has a dropdown menu, where you can pick the device style before creating the version… i dont know if that already existed and I never realized, or if it is new

1 Like

Pretty sure thats been there for a long while, i’ve always ignored it and left it on the default of phones i guess… and there’s no option for phone and wear os together in the same release

1 Like

Hmm actually the wear os track seems to be new… now to figure out how to do a watch face and a companion app

1 Like

This workaround seems to have worked. My .aab is under review, so we’ll see if it gets approved. Thanks for the tip, mm_aang.

1 Like

It seems like the correct way to do it now is to upload a watch aab to the wear os track and a mobile aab to the original phones track using the dropdown that dect mentioned. I did both at the same time and it’s under review now so i’ll see what happens.



I did the same, under review too, lets see what happens hahaha

1 Like

Interesting i usually first add previews complete all information upload and submit for review both aabs watchface and companion app together.

And afterwards at the end i add wear os form factor . Then add wear screenshots. And then agree to terms and conditions for wear os.

I uploaded this one on 8th March morning and it got approved released also on 8th March didnt have this issue. But maybe this rule got imposed after 8 Mar.

Keeping an eye now on your progress .
Do share the results here please :slight_smile:

Mine (again, app, not watchface) just got approved…

Mine too now :slightly_smiling_face: I dont see the option on mobile to install to watch yet but i assume it’ll just take a while; but on pc it works.

1 Like
  1. I filled out everything as usual. This is the name…screenshots…description. 2. I went to Advanced settings and there I chose the Wear type. 3. I pressed the working version. From the top next to the button where Create issue - a little to the left I switched the track to Wear device only. And uploaded the dial there. 4. In the same place, I switched the track to Mobile devices, Tablets … And the companion loaded it there. 5. Returned to the advanced settings, added screenshots for Wear and ticked the box to become a Wear member. Approved already 2 watch faces

Hi there, I have tried the above tips but I am not able to upload app bundle to a release. I keep getting the message " An error occurred while running bundletool build-apks on your uploaded app bundle. Ensure that your app bundle is valid by running bundletool build-apks locally and try again. Learn more. Error: Watch face cannot have any files in the root of the package." does any one have any idea? I am uploading the aab file published by Watch Face Studio. Thanks


Are you using the 1.4.13 Beta version of WFS if so you are not alone See this Thread

Unfortunately you can’t revert the 1.4.13 Beta project back to 1.3.13 release version you have to create a new project if you go back to 1.3.13

Samsung Developer Relations