Galaxy Watch Active 2 bluetooth issue

Hello,

Trying to send sensor data from Active 2 watch via bluetooth.

Environment details:
Galaxy Watch Active 2 SM-R820
Tizen 4.0.0.7
Wearable v4.0 Web Application
<tizen:privilege name=“http://tizen.org/privilege/bluetooth”/> set in config.

I always receive “Permission denied” on attempt to get bluetooth adapter:
tizen.bluetooth.getDefaultAdapter();

Tried to request permission:
tizen.ppm.requestPermission(‘http://tizen.org/privilege/bluetooth’, …
But the response is PPM_DENY_FOREVER.
Also there is no bluetooth permission in the watch UI: Settings -> Applications-> Permissions-> <My_app_name>, only “Memory” and “Sensors”.

Is it possible to use bluetooth with Galaxy Watch Active 2?

Hi,
I have found the same exception “Permission Denied” when I used TAU as project template. Choosing BasivUI as project template solved my problem. And also I do not need to request permission with tizen.ppm.requestPermission().

I think the issue is with the TAU library.

1 Like

Thank you!
The BasicUI project really works. Looks like there is some bug in the TAUBasic project template or in the TAU library.