I cannot specify the port for the IP Address that my watch is connected to?

I want to try my watch face on my device - I am on the same WIFI Network and I have debugging enabled on my watch. I am trying to specify the IP address of my watch in Watch Face Studio - but it will not let me specify the port (usually specified with a colon followed by the port number).

Does anyone have any ideas?


you dont need to provide port just 192.168.1.xx as the case maybe.
Dont include Port when the popup appears.

If you cant see watch after entering the IP, I will suggest, you close watchface studio app and reopen it and then try again.


in the debug mode, after enable wifi, wait few second and you will see your ip like 192.168.1.xx:5555 on your watch.
then , in Windows you have to go to WFS directory, tools, windows, and on “adb.exe” you have to click on menu “File”, “open windows powershell”, and then “open windows powshell as admin.”

then you write “.\adb connect 192.168.1.xx” and it will connect to your ip. Sometimes i have to close WFS and reopen it to see my watch on “connected devices”

Hope it will help

1 Like

@ tremal832
That really worked!!! I am thrilled!! Thank You Sir!!!

How to know THAT??? facepalm :see_no_evil: :man_facepalming: … and why isnt that doing the app when i manually enter the IP??? Maybe you have to start WFS as an admin? :thinking: