Upload error with new version

Exact same issue here. I uploaded 2 versions initially just fine, and then any subsequent versions come up with the “…root of the package” error.
I’d love to know where I’m going wrong

I’m having the same issue, I’m trying to use the latest beta to see the sync-to-device step goal, but I think this feature is also not working. I’m new to this forum, is there a moderator that will see this post and act on it?

I update for the first time with the new version and it’s ok but I can’t install it through the complication app.
When installing on watch will ask for permission, but there is no accept and only Cancel.
Too tired of google.

Sync with Device will not be enabled until Wear 4 is released and installed. Until then it is set to default of 6,000 steps.
See FAQ’s 11,12 and 13 for WFS 1.4.13 beta issues

Samsung Developer Relations

Hello, Ron! Can you provide any insights into what might be causing problems with this:

An error occurred while running bundletool build-apks on your uploaded App Bundle. Ensure that your App Bundle is valid by running bundletool build-apks locally and try again. Error: Watch face cannot have any files in the root of the package.

If you are just following instructions from WFS documentation it may not be correct.

See this thread (in this case people were uploading an Android companion app and Watch app at the same time) but how to upload a watch app changed in March and may be your issue.

also see this Play Console documentation for publishing Wear Apps

Samsung Developer Relations

no, that is another issue, and yeah, it was related to using the wrong track (not Wear OS only).

For this topic, I suddenly can’t publish anything from Watch Face Studio. Uploading any build from WFS leads to the same error.

@mikhail @Sen @Uninhibyted @AnakaraKool

I can’t contact the WFS team now I am off for the holiday weekend and they are in Korea. I’ll send them a letter.

It is a very bad idea to upload content developed with WFS 1.4.13 Beta to the seller store. It is probably going to give a bad user experience and you could get bad reviews.

There a lot of issues being reported on this discussion about quirks when run on a device.

Samsung Developer Relations

1 Like

Appreciate it, Ron.

We’re looking forward to receiving an update from the WFS team.

Enjoy a fantastic holiday weekend!

oh, I get it. thanks for the answer.
I’m waiting for the update on the error reported by OP about uploading in the play store. thanks, Ron

Can confirm this is an issue. Maybe it’s WFS 1.4.13, maybe it’s because of how Play Store handles new Watch Face format? Definitely needs urgent fix.

screenshot_ 8-34-18screenshot_ 8-34-08

1 Like

Exactly it. I’m stuck with 2 faces created by beta, and no way to fix it yet.
I have recreated the face with the old version and uploaded it but it has not been approved by google.
The beta version is so bad with silly bugs, it should be warned that it’s unstable and has bugs…
Since GWD has always been in beta before, it’s easy to get confused when releasing a beta version of WFS without a warning.

Very same issue here. I was really frustrated, still am, but now I found this thread and hopefully it will have a fix.

1 Like

I’m in the same situation, I am just trying to release my first build and I run into this issue. I don’t want to recreate the whole thing. I need to stop joining in on beta versions. I hope we get a fix for this soon.

I agree and think the release notes should have at least had a warning since there is not going backwards. I usually get the release a few days ahead of time, so I will be much more careful about this in the future.

Having said that in the WFS team’s defense they are not used to the previous teams always beta methodology.


1 Like

An error occurred while running bundletool build-apks on your uploaded App Bundle. Ensure that your App Bundle is valid by running bundletool build-apks locally and try again. Learn more. Error: Watch face cannot have any files in the root of the package.

Hello Ron,
I hope you are fine…

Any updates on this…?
I have made a watchface and can’t submit it to the Playstore…

It would be great if the WFS Team could release an update allowing us to import from the beta and build on a stable release…

Or perhaps an ETA for the fix would be appreciated as well…

For people who created a watch face on 1.4.13 and are looking to downgrade, it is possible with a little bit of work.

I can’t say there wouldn’t be any possible bugs involved with the downgrade but I’ve manage to build a watch face.

Steps to downgrade project file:

  1. Extract the project.wfs file as a zip file
  2. Open honeyface.json
  3. Change projectFileVersion from 1.110413 to 1.110313
"projectFileVersion": "1.110313"
  1. find “appLabel” and change the object value to a string instead of an object (this should prevent a crash during the build phase)


 "appLabel": {
            "stringResId": "ID_LABEL_EXAMPLE"


"appLabel": "EXAMPLE"
  1. Zip files and change extention to .wfs
  2. Open project file in hex editor (or write a quick script) and append these 16 bytes to the end of the file (this tells the app that the zip file is a valid watchface project.)
6E 6F 72 6D 61 6C 5F 77 61 74 63 68 66 61 63 65			normal_watchface

I managed to get that to work, I don’t recall if I did anything else tbh. I may have resaved it after opening it.


You are truly a saint…
Downgrade success, but I can’t build because I have three strings. Should I delete all strings?

1 Like

3 strings under “appLabel”? If so then yeah.
As long as appLabel becomes a single string instead of an object it should work.

from there if you’re still getting crashes a good way to figure out what’s causing the issue is to compare a project’s honeyface.json from the older watchfacestudio with the honeyface.json from the beta version.

Example (Left: 1.4.13 Beta, Right: 1.3.13):

As far as I can tell the crash causing line should only be appLabel as it tries to find a single string there but finds an object.

It’s also possible you may be able to just remove the entire buildData block but I’ve not tested that.


That did the trick, alongside replacing a few animations…
Built and published to PlayStore…
Thank you so much…

But I think the beta should have backward compatibility in the future…

1 Like