Watch Face Save issue when add image sequence

Issue in version 1.5.7(beta) 1.6.9(beta)

When I create Image Sequence and then try to save it’ll not save. And adding anything else after add Image Sequence will lost too.

There is no problem with the images as I have also changed the images but am not able to save them either.

I also tried Sample Hill_house_square watch face project images


I used sequence image before no issues… tried the sample image?

I tried Image of my own and also tried Hill_house_square watch sample demo watch face notification images

Dont know why, but on 1.5.7 my watch image sequence worked…

If u just used single image components…can u save it?

Maybe others can help u out…

Are sure your workspace is not write protected

If you expect to see all the images in the work window after you add more images you won’t you will only see the first image. You need to run it from the run window to see them run.

Read Jakia’s blog on Animation in WFS and see if you are doing something incorrectly.

Samsung Developer Relations

1 Like

I Record a screen please check it here is we transfer link because file upload limit is 8

valid for 7 days only because it’s free

Hi can you do a save as instead?
Not sure where is your build folder…

Like i said i just tested i have no issues

1.5.7 (beta)

so its something to do with your computor or image size , or something.
not WFS

uninstall and reinstall your wfs, and create a new project. reimport you images. from scratch.

1 Like

You have a notification in the pancake menu what does it say that should be for a version update.

Are you running two versions of WFS at the same time? Did you install for just you or for all users?

You open FlexWindowCustomization but the bar on WFS says Sample Watch face so when you save that is what you save too not FlexWindowCustomization.

If you go to
C:\Users\USERNAME\AppData\Roaming\WatchFaceStudio\dump There is a log generated delete it and then do this again and it should tell you what is wrong. It should be pretty obvious.

Samsung Developer Relations

1 Like

I look at the video closely he didnt open FlexWindowCustomization. He switch to stared project and open sample watch face instead.

1 Like

Thanks for replay guys.

I have latest version installed and still it shows that red dot.

I tried different images and it works but not this images it’s look fine to me but not working. I’m attaching that image folder. And also that sample project (262.4 KB)

I delete dump files and tried again i get below log :

[WFS-1.6.9][main][15/03/24, 10:24:00][I(main.js:1)] [MAIN] dump is true
[WFS-1.6.9][main][15/03/24, 10:24:00][b(main.js:1)] Not first execution after installation
[WFS-1.6.9][main][15/03/24, 10:24:02][WebContents.<anonymous>(captureListener.js:1)] [childWin][RunPreview][did-create-window] id: 2
[WFS-1.6.9][main][15/03/24, 10:24:04][undefined(ResourceData.js:1)] Try to delete invalid resource:tutorial_swipe_back.json
[WFS-1.6.9][main][15/03/24, 10:24:36][WebContents.<anonymous>(captureListener.js:1)] [childWin][OffScreen_ScreenCapture][did-create-window] id: 3
[WFS-1.6.9][main][15/03/24, 10:24:36][undefined(ProjectController.js:1)] RangeError [ERR_OUT_OF_RANGE]: The value of "value" is out of range. It must be >= 0 and <= 4294967295. Received -333370432
    at new NodeError (node:internal/errors:405:5)
    at checkInt (node:internal/buffer:74:11)
    at writeU_Int32LE (node:internal/buffer:694:3)
    at Buffer.writeUInt32LE (node:internal/buffer:707:10)
    at Object.dataHeaderToBinary (E:\WatchFaceStudioBeta\resources\app.asar\node_modules\adm-zip\headers\entryHeader.js:255:18)
    at Object.compressToBuffer (E:\WatchFaceStudioBeta\resources\app.asar\node_modules\adm-zip\zipFile.js:257:49)
    at Object.writeZip (E:\WatchFaceStudioBeta\resources\app.asar\node_modules\adm-zip\adm-zip.js:744:32)
    at E:\WatchFaceStudioBeta\resources\app.asar\dist-electron\electron\project\ProjectFileMaker.js:1:2096
    at new Promise (<anonymous>)
    at B (E:\WatchFaceStudioBeta\resources\app.asar\dist-electron\electron\project\ProjectFileMaker.js:1:2032)
    at oe (E:\WatchFaceStudioBeta\resources\app.asar\dist-electron\electron\project\ProjectController.js:1:1867)
    at E:\WatchFaceStudioBeta\resources\app.asar\dist-electron\electron\listener\util\listenerUtil.js:1:685
    at WebContents.<anonymous> (node:electron/js2c/browser_init:2:88656)
    at WebContents.emit (node:events:514:28) {
  code: 'ERR_OUT_OF_RANGE'
[WFS-1.6.9][main][15/03/24, 10:24:44][undefined(ResourceData.js:1)] Try to delete invalid resource:tutorial_swipe_back.json


I tried new images which is not working before and i know why because after upload that specific images whatever i add not saved .

I Imports in photoshop and export that images which i try to add in image sequence and now it’s working fine. Please check my previous reply i added image folder which is not working in my pc .

So i think problem is that images. sorry for waste your time.

Thank you replies I really appreciate. Have a good day. :smile:

Maybe resolution or something…usually i do quick export to png. Dont have issues with photoshop default settings.

Not sure why but your date modifications of the files is 1st jan 2098? Something not right with the meta data of the images

1 Like