Battery Historian documentation errors

The documentation on https://docs.tizen.org/application/tizen-studio/native-tools/batt-historian/ contains at least two errors:

  1. sdb root on is not permitted, but I think it is also not required to pull the dumpsys
  2. In the command dumpsys batterstats > /tmp/battery_stats.txt the “y” is missing in “batterstats”.

Hello inf1592056328,
As you’re working with the commands, I guess you’re dealing with linux terminal.
If you’re doing so then did you try to turn on sdb root with super user access?
Would you please check that you still get “not permitted” error with the super user access?

And, we really appreciate your effort of reporting such mistake on an official guide. We’ll escalate it to the relevant team.

Thank you!

I don’t think this is a problem of the execution rights on the host where I’m running sdb. It’s sdbd or the device that does not allow root mode. I just gave it a try anway and as expected:

# whoami
root    
# sdb root on
Permission denied

I wanted to make sure by checking the sdb source code but the one I found on https://git.tizen.org/cgit/sdk/tools/sdb/ is very outdated. Is the source code for the current sdb that is shipped with Tizen Studio available or is it closed source?

Hello inf1592056328,
From your last reply I can find ‘#’ sign before the command sdb root on.
Would you please ensure that you’re running that command for shell instead of linux terminal?
‘sdb’ commands are available for the Smart Development Bridge (SDB), linux terminal should not be aware of those.

I don’t understand. Can you please elaborate on what exactly you are meaning?

I’m running the sdb binary which is in the /tools directory of the Tizen Studio installation as root on my Linux or OS X machine. The ‘#’ is there to indicate that I’m running it as root. What exactly do I have to do differently?

Also regarding my second question: is the current sdb of Tizen Studio open-source?

What I tried to say in my previous reply is that you should turn on the sdb root in shell command terminal not in Linux terminal because sdb command will not be recognized by the Linux terminal.
And, about the sdb being open source, its not open source. The source code is not available publicly.