Error occurred while downloading APK. Try later

So infuriating and vague. I get this message about half the time on the Chrome Themes Studio application. I randomly go in and start changing things and can inconsistently get projects to eventually export. It’s frustrating that all it says is “Try later.” At least give me an error code for a direction to go in. I know nothing of programming but I imagine if there’s an error, there’s communication somewhere where/what the error is. So I hope in the future that the notification to the developer will include an error code or something.

You don’t really need an error code - it’s always because the servers are overloaded. All you can do is try again. :frowning:

1 Like

Ah, I see. Thanks for the reply! I’ll keep that in mind in the future.

It’s not correct!

When I can’t by computer, I can download it from Chrome on my phone without any problems! The error always occurs in version 2020 (Android Q). Rare times that I can download the 2020 version apk by the computer. Version 2019 (Android P) I always download without problems. So, congested server is a lie.


I used to have problems with the cinema hd apk app when I installed it on my smart TV, the way I solved it was to check the amount of memory, update to the latest version of both device and application. Try them out.

1 Like

Yeah I don’t remember ever having an export error on the PC tool but I don’t use it anymore because I thought they weren’t updating it anymore. Thanks for your reply!

Have you opened a ticket when you get the problem - provide date and time? I did and have been told that it was a resource issue every time. I have not had a problem in the past month. Let us know what your ticket response is please.

1 Like

I did a 1:1 inquiry through the Seller Portal and they told me they didn’t have enough information to determine the issue. I was able to get it exported by then so I didn’t follow up. I was hoping to see if anyone on this side of the program had the same issues and what they had done. If I do come across it again where I absolutely can’t export and open a new inquiry, I’ll post here with what we find.

1 Like

I was having problems running the visibility check and creating an APK last night. I was logged in to GTS all day, and I think that may be the problem. I logged out, cleared cache and rebooted and GTS worked fine.

1 Like