Install by URL KM24A Kiosk


I am working on a KM24A device (Kiosk). I managed to install it from a USB Key, but I didn’t have success by URL.

I don’t think the problem comes from my package. It might be the configuration of my web server (OVH).

If anybody got a solution or/and can explain it. I Will be happy to discuss this.

I will help everyone with this info.

Actually, with some of the server providers, you get a free SSL with Let’s Encrypt.
But unfortunately, it’s not recognized by Samsung. I have no idea why it’s not supported.
Then I tried with ZeroSSL, and the install by URL works fine.

I would like to know why is not supported. Because of course that includes another cost.

I’d request it this at the Smart TV Seller Office, it may be they aren’t aware of it or if there is a reason they can tell you why.

Samsung Developer Relations

@johann.six do you mind sharing how you got it working via usb?
I have followed this guide: but still get an error installing

Hi, I followed the same guide.
I made my app and compile it into a WGT.
Then I create a pkginfo.xml with the following.

<?xml version="1.0" encoding="UTF-8"?>
<pkg name="myapp" type="Kiosk">

With these two file. I made a zip (If you are on Mac OS you need to be sure there is no DS_Store and other hidden file), with the name
Then made a file usb_kiosk_config.xml

<?xml version="1.0" encoding="UTF-8"?>

And put the and the usb_kiosk_config.xml in a folder kiosk in the root of your USB key.

You should get this.

└ kiosk
  ├ # myApp.wgt & pkginfo.xml
  └ usb_kiosk_config.xml

Now just plug it into the Kiosk and install it. This should work. If not the problem might be from your wgt.

1 Like

@johann.six thank you so much for responding. I still have the error, but I think you are correct about my .wgt. for simplicity, I’m trying to get the analog watch sample but that doesn’t work either.
my hunch is that it may be related to certs, do you have any guidance around that?

You welcome,
The best way is to make it simple.

Because some of the CSS or ES6 are not fully supported yet.

After you need to update your config.xml and the permissions/privilege.
Here is the list : Tizen permission/privilege