Ranged value complication progress bar bug

There seems to be a bug with the progress bar when using a ranged value complication.

If you have the background opacity to anything above 0, it will still be displayed even if you select none from the complication selection on the watch.
On WFS when you select none the bar doesn’t show up, but on the watch it will be displayed according to the background opacity that you have set.

Was it intended to work as such or is it a bug?


I have also seen the issue in my end. You can create a support request along with a wfs file and images.

Hi. Just add layout where only progress bar is visible and hide it with that “eye” symbol.

  1. Add first option (Progress bar) layout:

  2. Hide it

1 Like

But i want the progress bar to be visible when i have a complication selected, for example chance of rain.
Then if you select none as a complication all the elements will be hidden except the bar’s background opacity.

So i want to use the bar but i want it to hide like the rest of the elements when i do not have a complication selected/enabled.

I know what you’re trying to achieve and believe me, this will help. Just test it with two layouts

  1. Progress Bar only (hide it)
  2. Progress Bar + Icon

Try setting battery as a complication data provider. It will show progress bar + battery icon.
Try setting “None” - no element will show

1 Like

Just tested it and it works! makes no sense why it works though.

Thanks for the help.