SDK policy denied error

I have created an app to collect PPG data with privileged Samsung health SDK as I have already registered with the program but while starting the activity to collect the data I am getting the error that SDK policy is denied then I have raised an query to support staff about my registered package name and that seems to be the same.
so please help me that why I am getting this error.


I believe you should raise this issue directly with the Health team if you can. If not you can report it in the Developer Support channel.

Hope that helps,

Samsung Developer Relations

i am facing same issue.
have priv-health-tracking-v1.1.0.aar under libs folder.
i am using the example code that came with privilege health SDK
when i run any activate i initially see “Connected to HSP” Toast
then when i click on “Start” button in any activity it immediately says “SDK Policy Denied” from TrackerEventListener

i have these in manifest

<uses-permission android:name="android.permission.WAKE_LOCK" />
<uses-permission android:name="android.permission.BODY_SENSORS" />
<uses-permission android:name="android.permission.ACTIVITY_RECOGNITION" />
<uses-feature android:name="" />
    <package android:name="" />

and installed app via adb install -g APP_NAME.apk

Did you get any solution by far?

@r.liechty_SDP, i am replying here as i didn’t hear back from Developer Support Channel
Any help is appreciated

Thanks for the heads up I can and will check on this next week.

Samsung Developer Relations

From what I’ve seen you get this error if you don’t have Developer Mode set on your Watch.

If that isn’t it then open a developer support request and include as much information and any screen shots showing the error message.

Samsung Developer Relations

Hi Ron,
Thanks for your reply.
i did read in documentation about Health Platform Dev Mode but seems like currently we will be on waiting list to register our app (please correct me if i am wrong)
is there a way to enable dev mode for Health Platform via adb?
there are few devices and hard to do it manually for each devices

No you need to do it directly on your watch.

Go to settings scroll down to about watch
scroll down to software version
Tap at least 5 times on that and it should enable Developer Mode

You only have to do this one time it stays.

Samsung Developer Relations

Hello, I have the same issue when running the ECG monitor app from the Doc. “developer Options” already activated.

This error is not shown when using HeartRate & SpO2 codelab.


I don’t think ECG’s are allowed in all countries only a few.
ECG & Blood Pressure on Galaxy Watch 4 are officially available in the following countries: Austria, UAE, UK, Belgium, Bulgaria, Croatia, Chile, Czech Republic, Denmark, Estonia, Finland, France, Germany, Greece, Hungary, Iceland, Indonesia, Ireland, Italy, Latvia, Lithuania, Netherlands, Norway, Poland, Portugal, Romania, Slovakia, Slovenia, South Korea, Spain, Sweden, and Switzerland.

If you aren’t in one of those that may be why. If you are then open the support request.

Samsung Developer Relations