Server aws error when trying to download watch face studio and android

Cannot download watch face studio or android usb driver says error 403

1 Like

Yes. Even I am unable to download Galaxy Watch Studio.


The request could not be satisfied.

Request blocked. We can’t connect to the server for this app or website at this time. There might be too much traffic or a configuration error. Try again later, or contact the app or website owner.
If you provide content to customers through CloudFront, you can find steps to troubleshoot and help prevent this error by reviewing the CloudFront documentation.

Generated by cloudfront (CloudFront) Request ID: hinDtW-K34AFZDL4sPvCvER3yF0j6pUdi6HHE1i13lBv2rBOGxZOjA==

@jdunham & @assn898

I can duplicate this on one computer but not another. It looks like the modified the portal last night and it isn’t propagated out fully.

I’ll report it.

Samsung Developer Relations

1 Like

Hi all. I’m Ron’s manager and I oversee the operation of the developer portal. I’m not seeing this problem, but I will check with the ops team to see if they are seeing an issue in various regions (AWS). I was able to download the USB driver and WFS, but it could be region-specific.

Apologies for the problem. We’ll get it resolved.

1 Like

I’m getting an error trying to log into the Forum… can only accessc through the app.

I cannot download WFS, either. I’ve tried from computers in multiple geographic locations on multiple ISPs (Comcast in Chicago, IL and Level 3 in Newark, NJ). Same 403 error as above.

1 Like

Any chance there is an alternate download location? Even an archived older version of the software would be acceptable temporarily (and I’d upgrade once the latest version became available again).

Hey there. I’m getting the 403 error as well. I’ve tried multiple browsers - no bueno. I’m PNW USA and have been having the problem since morning. There are people on Reddit r/GalaxyWatch noting the problem as well.

It has become available to me now, at least via my Chicago Comcast connection, so perhaps it’s fixed for everyone?

1 Like

It has become available to same region