Tizen Download API issue when using HTTPS

I am currently facing a challenge while using the Tizen Download API. When I run it on the Tizen 7.0 Emulator, the download process works smoothly. However, when I try to run it on a Samsung Signage 32" device with Tizen 4.0, the download process does not work at all. After a few seconds, it displays an exception stating, “Connection timed out.”

Upon investigating further, I discovered that the issue lies in the usage of the HTTPS domain. If I use the HTTP domain, both the Tizen 7.0 Emulator and the Samsung Signage 4.0 device can download without any problems. However, when using the HTTPS domain, only the emulator with Tizen 7.0 is able to download successfully.

I would like to inquire if there is a solution available to enable downloading from URLs with the HTTPS protocol on Tizen 4.0 or earlier versions. Your assistance in resolving this matter would be greatly appreciated.

Additionally, I have tried using a third-party library called Axios, which can download files from HTTPS URLs. However, I am still facing difficulties in converting the response types, “stream” or “blob,” into a file format and storing them using the Tizen Storage API. It seems that the Tizen Filesystem API does not provide the “openWriteStream()” method to handle response data streams.

If you have any suggestions or solutions regarding these issues, I would be grateful for your guidance and support.

Thank you for your attention and cooperation. I look forward to your prompt response.

I know that the access to Singage and hospitality TV’s is different than normal TVs but other than that I don’t know anything so I can’t help.

Since no one responded, I would suggest you look for an answer in the FAQ-Q/A under the most appropriate topic on the Smart TV Seller Office site If you don’t find a solution there then sign in and open a Smart TV Seller Support Request . They can help you better there.

Samsung Developer Relations