User-agent switcher does not work well

Use the desktop version of the user-agent in Samsung browser to visit some websites still display the mobile version.

I think you’re using subdomain like or etc check your url first

Thx for your reply. I’m sure that I am visiting the desktop URL, but it’ll redirect to the mobile website and add “m” in URL, which means the server identified the browser as a mobile device. I try to alter the user-agent string of debug setting, replacing the “Samsungbrowser” with “Browser”, and the problem was solved. When I reopen the browser, things happened again.