Volume in Web app on Galaxy Watch 3 not working

Hi all,

I have web app and i use tizen.sound.setVolume.

But not working in GW3.

Working only:

tizen.sound.setVolume(‘MEDIA’, 1)
tizen.sound.setVolume(‘MEDIA’, 0)

No number in between works.

Any ideas, please ?

In Emulator Tizen 5.5 works perfectly.

Hi, I have the same issue.
On Watch3 tizen 5.5.0.1 tizen.sound.setVolume(“MEDIA”, X) with 0<X<1 throws an exception:

VM18:1 Uncaught WebAPIException {code: 20, name: “AbortError”, message: “Internal error”, stack: “AbortError: Internal error↵ at NativeManager.ca…lume (:1:2520)↵ at :1:13”}
NativeManager.callSync @ VM18:1
SoundManager.setVolume @ VM27:1
(anonymous) @ VM364:1

Only tizen.sound.setVolume(“MEDIA”, 1) or tizen.sound.setVolume(“MEDIA”, 0) works
My question is: why is working fine on tizen 4.0 and not anymore on Tizen 5.5.0.1 despite the documetnation ?

Hi @pav1587879547 I received an update from the relevant Samsung developer team. They will fix this issue on the platform side in the upcoming firmware update. At the moment they haven’t provided any specific schedule time.
Really thanks to @Iqbal for the support !

1 Like

You are welcome :innocent:

1 Like

Great. Thank you for your info.