Adding watchfaces to google playstore in 2024

Hi,

I’m Kev, I used to design a lot of watchfaces for Samsung galaxy watches in the pre-pandemic times, then a lot of stuff happened and I decided to focus on my day job instead of my watch brand.

I recently decided to look in to things again, and I need help with the transition from Samsung Sellers to Google playstore as a sales venue. I haven’t yet looked in to my marketing materials, and I probably have to resize som pictures and whatever, but I have over 200 watchfaces that are pretty much ready to be converted in WatchFaceStudio and then sold via Playstore.

However. Here’s the hurdle. to quote google playstores requirements for publishing:

"To help all developers to deliver high-quality apps, we’re introducing new testing requirements. Developers with personal accounts created after November 13, 2023, will need to test their apps before those apps are eligible to be published for distribution on Google Play […]

[…] If you have a newly created personal developer account, you must run a closed test for your app with a minimum of 20 testers who have been opted-in for at least the last 14 days continuously. When you meet these criteria, you can apply for production access on the Dashboard in Play Console so that you can ultimately distribute your app on Google Play[…]"

Should I interpret that as me needing to find 20 testers, to run each and every one of my watchfaces for 14 days before I can publish them?

This feels to very much like it kills any potential profitability of venturing in to watch face making, even for someone who has pre-created assets? Does anyone have a workaround for this? It is obviously a rule created for app makers not for watch face makers.

All help is extremely appreciated. How can I get started again? I really appreciate making watch faces.

Ps. really nice to see some names I recognize on there from back in 2019 when I sold my watchfaces by your sides. Really happy some of you are still in the game!!

I’m running into the same obstacle. I’m currently in the process of trying to publish a watch face just to see if that requirement holds true for watch faces as well as more traditional apps. So far I haven’t gotten that far in the publication process (Google really does not make the process simple or straight forward). But I’m hoping, if it is true, that maybe this forum can be a place for us to get testers. TBH, I don’t know 20 people who have an Android smart watch.

Hi, u could post link here to the test version of your app maybe some one from this forum including me can help u test.

Provided your design doesnt infringe copyright laws.
And its clean (no malware , scam etc)

I on gw 5 pro btw.

Thank you for your willingness!

I just completed the process for getting a closed testing release on my first watch. Here is a link through Google Play so you know it is clean. I will probably make a separate post shortly requesting more testers. They require 20 testers for 14 continuous days. I appreciate Google trying to increase the quality of their store, but… I don’t like how it affects me :confused:

https://play.google.com/store/apps/details?id=com.watchfacestudio.swoopD

Edit: And me clicking that link, it doesn’t seem live at the moment. I wonder if there is a delay before I can even launch the closed test track.

Your link still not working

It seems Google has an approval process before they will even let you do the closed testing. I’m currently waiting on their approval. I’m starting to question whether it’s worth it to list through their Play Store with these new requirements.