[AMPM] displaying as a.m. / p.m

I found this weird, might be a bug?

I made my digital clock with the tags:
([HOUR_1_12_Z]):([MIN_Z]):([SEC_Z]) ([AMPM])

in the workspace and build preview it reads as 03:03:03 AM
but on my watch it reads as 03:03:03 a.m.

I tried re entering the tags and saving right away before pushing it, but it keeps going back to the latter.

anybody encountered this?

Hah Yes I did in one of my watch faces. I just checked and for text formatting I mistakenly had tt instead of Tt. I haven’t tried to run it yet but could that be your issue too.

Ron
Samsung Developer Relations

I would check also the language settings of the text field. In GWD it was possible to check language settings in preview, in WFS there is everything only english, no matter what default language you pick. Can be that for different english dialects the ICU source has different abbreviations

1 Like

@r.liechty_SDP you pointed me in the right direction… it was set as Tt.
It should have been TT (all upper case), after changing it it now has capital AM but there is still periods between the letters lol… its displaying as A.M. on my watch as opposed to AM without the periods as it shows on WFS and Run window.

I don’t but it may be just the locality AMPM returns the local setting and it could be that it is with a period in Montreal and not in Newfoundland. I don’t know if that is it or not. What does your mobile have?

Ron

1 Like

this is interesting… I changed the language to english (usa) and it changed to AM/PM without the periods!

But, I can’t change the time format on the AOD, it doesn’t give you language options and it still shows a.m./ p.m.

The difference between a clock component and a text component I suppose.

I changed the AOD to a text + digital clock to match what I had and changed it USA English. Now it looks how I want.

were making progress lol.

The local language support for the preview window does not work so it would be different on the watch if other than US English is chosen.

Correct since it only has a limited vocabulary of translations it can’t translate text. Use the clock component it the AOD but no second tag. Be sure it does not show in the normal mode. and the normal mode clock does not show in the AOD mode.

Ron
Samsung Developer Relations

1 Like

yah I saw it wont let you add a seconds tag in AOD.
correct, I buried it underneath the bottom of my background layer so it wont show on normal mode, only AOD.

Thanks Ron!

There is a little eye icon on the right of the layer list when you hover over it click that to show or hide. a component. That way it isn’t using any power in Normal mode.

Ron

thanks for that tip. I didnt realize it would use power even it weren’t showing. Ill do that!