Android 12 App links not working

Hey everyone,

I have ran into an issue where verified app links do not trigger a redirect to our app on Android 12. All of the previous Android versions work just fine. Changes that have been made to web intents in Android 12 are addressed in our app and we have verified our domain with assetlinks.json. All other browsers that can handle deep linking work just fine as well. Are there any known issues regarding app links with Samsung Internet on Android 12?

1 Like

Can you give an example of it, like a screen recording or an app link here?

With this app link we redirect users back to our app after Auth0 login ( uri example:…)

Android 10 Samsung Internet:

Android 12 Samsung Internet:

App links tester Android Studio:

I understand the problem. Please repost the URI since the full link wasn’t pasted correctly.

Full URI:

Is the URI working for you? It is not redirecting me regardless of the browser. Maybe the auth token expired?

Yes the auth token is old, but it expires too quickly for me to be able to post a valid one here. Maybe you could download the Bankera app and test it out this way?

Did you solve this issue? I currently experience the same problem. It works on other Android 12+ devices, but on Samsung the auto verification does not work and all links open in the browser.

Also the option to manually verify is quite hidden, which is a terrible UX. Any feedback is much appreciated.


We haven’t solved the issue yet and I hope that this thread catches some attention as I believe we are not the only ones experiencing this.

Does anybody know if this problem is only in Samsung devices?
Are there any specific versions?

I have the same problem, but I don’t have the device specifications (I’ll try to get it).
On Pixel 5, Android 12 works fine.

We have confirmed with our application that this ONLY happens on Samsung devices running Android 12.

Not a single other device on the market has this problem, and it boils down to this: for some reason, Samsung is ignoring the assetlinks API response from Google, or has broken it with their changes.

How do we know? We can take two completely clean devices, an S21 and a Pixel 5, and install the application from the Play Store. We send a deep link to an email address, access it via those devices, and we see two completely different behaviors. When looking at the application info, we notice that the Samsung device defaults the option for handling links to “off” for our domain.

I don’t know if it’s because we have wildcard deep link handling, or Samsung has just plain broken them all, but we can confirm with Google’s own APIs that our app is verified to handle these URLs. We suspect, but can’t prove, it’s wildcard-specific because a non-wildcard hostname used by one of our marketing vendors is handled just fine.

Samsung needs to work VERY HARD to get this fixed rapidly or provide us with a reasonable work-around. This is ruining the experience for a LOT of applications, including some that are in the top ten lists.


We are facing the same issue on Android 11, and 12 as well.

Applinks are not working even on Galaxy s8, android 9, Samsung Browser v18.0.4.14.

Im having the same problem. I’m trying multiple ways to get the applink working. If I write the applink on notes and click on it it works. If I click from a web page it doesnt.

Hello, I had the same problem today with a Samsung device and have really long searched for an error in the code.

Every time I tried to open my deep link with https scheme from the email, Chrome opened instead.

I looked in the smartphone settings to see if something was preventing the app from reading the link.

See, under Settings → Apps → My App → Set as Default → Supported Web Addresses, all my deep links were simply disabled. After I enabled them, everything worked fine again.

We are currently trying to find out if this problem will occur on every Samsung device.