Android USB Driver

Hello,
I want to connect my mobile (Galaxy A12) to my computer (Windows 7).
I’ve tried to install the Adnroid USB driver for Windows 1.7.56, available on the website, but it was not possible : “Code signature verification failed, Exit installer, Error failed verifying trust”.
How can I do ?
Thanks

@stephan.vonfelt

Try downloading the file again. When I tried to download it Tuesday it failed to download. But today it downloaded quickly. If it still doesn’t work I would guess that Windows 7 is no longer supported but you can open a support request about that.

Ron
Samsung Developer Relations

Hello,

thanks for your answer.

The download works, but not the installation of the driver (see my initial message of September, 5)

Greetings

I hope it’s o.k. to do a “me too” here.
I’m also trying to connect an android phone to a Windows 7 system (A Galaxy J3 if it matters. The phone connects in MTS mode so I know the device and USB cable are o.k.
I downloaded 1.7.56 and it ran and installed a driver: but the driver won’t start. Also, the driver that gets installed is 6.1.7601.18208 signed by Microsoft. I’ve tried deinstalling and re-installing to no avail.
Is there a good way to override this and get the ‘proper’ driver? Or is this the only one available.
I know Windows 7 is old, but there are very good reasons why some of us are still using it.
Alternatively: what I want to do is link the phone in Audio mode, which appears to require the Android driver. Is there another way to do this?
I searched, but could not find an answer in the FAQ.
Thanks.

Looks like I posted in haste.
It occurred to me that I should have tried installing the driver but WITHOUT plugging in the USB cable to the Galaxy 'phone.
I unplugged the 'phone, de-installed the Samsung_ANDROID driver, and ran the SAMSUNG_USB_Driver_for_Mobile_Phones.exe again. I was watching Device Manager while this was running, and instead of installing one Samsung_ANDROID driver it installed three separate drivers. They went by to fast to write down, but they installed with a success code, and now device driver shows “SAMSUNG Mobile USB Composite Device” under USB controllers and “Galaxy J3 Prime” under Portable Devices and “SAMSUNG Mobile USB modem” under Modems, instead of the android driver under “Sound, video and game controllers” which was coming up before and not starting.
I haven’t done any testing or programming yet, but this appears to have at least fixed the installation problem.
If you tried to install the driver with your Phone or other device attached, try unplugging it, delete the old driver, and run the driver installation program again.

Many thanks. In the while, it appeared that the problem of usb transfer originated from the hardware, and not from the driver.

Greetings