Unable to enable USB debugging on Galaxy A32 5G


I have an Android app used internally at my company. I have installed it on multiple Android phones, just by enabling USB debugging on the phone and connecting it to a computer running Android Studio. But I am unable to do this on an employee’s new Galaxy A32 5G. I have done the usual things, enabling developer mode then turning on USB debugging. I have tried with Android Studio running on a MacBook and on a PC running Linux and Windows (the last after installation of Samsung’s USB driver). I have submitted a query to Samsung developer support but they have not responded. I’d really appreciate some help with this problem, becuase if it can’t be solved I’ll have to make the employee get another phone, or buy it for him.

Hi Matthew,
I think somehow your pc is not recognizing the A32 device. You can try installing the Samsung Galaxy A32 drivers manually in your pc. It should work.
Let me know the status.


I downloaded the USB drivers from the Samsung site as well as the Google USB drivers. Then after trying a few other things I did get it to work under Windows. Still not working under Linux. It shouldn’t be this hard.

Matthew Fleming

I have found some steps over internet document about linux. Try this out first and check whether your pc can able to connect your phone or not.

Hello, I know the topic started off with Windows / Linux but I am also having an identical problem getting my Mac to recognize my Samsung A32 (SM-A326U). I have Developer options on and even set the default USB option to “Transfer Files”.

I have a different A32 Model in my possession that is recognized by my Mac with no issues.

I have restarted both phone and my Mac already but the A32 is just not being recognized via USB to my Mac.

It doesn’t even show the USB connected options in the notification area. It only shows the “Cable charging” under the “Settings” in the “Silent Notifications” area.

It’s running Android 11 on OneUI version 3.1. Not sure if any other information would help.