USB connection not working to PC

I develop in Visual Studio 2022 for Android and was previously connecting without problem to both my Galaxy Tab A7 and Galaxy Tab A (2016). The latter is running Android version 8.1 and can’t be updated anymore. Both tablets worked fine for debugging my program.

However, recently the A7 quit connecting to the PC over USB. It charges from the USB port but the PC does not recognize that anything is plugged into the port. Since the old Tab A still connects fine I assumed the A7 must have a bad USB C port and so I picked up a new S6 tablet. However, it also fails to connect!

I tried the Samsung Android USB Driver for Windows v1.7.59 but it makes not difference. Something seems to have happened in the latest Android update to make the USB not work.

Has anyone else seen this problem and been able to resolve it?



It used to be a setting to transfer data via USB I don’t remember what it was look for something like that
Also check your Developer Options and make sure that the allow USB settings are all enabled.

Samsung Developer Relations

Ron, thanks for the reply. Of course I have developer options turned on as well as USB debugging.

Can you be specific about any other options I should look at?


It could be the cable, try another one? I’ve had that be the problem connecting my phone to my laptop…

Check this setting.

  1. With the device powered on, insert the USB-C end of the USB-C cable into the device.
  2. To place the device into the correct USB mode, swipe down from the Notification bar then select the Android System notification.
  3. Select Transferring files or Transferring images.


A combination of things has solved my problems. The first was apparently the USB C cable. I had used this cable for years with the Galaxy Tab A7 for debugging my Android app over USB. So I bought an S6 Lite to be able to try both a new tablet and a new cable. To my surprise, the new cable made the Galaxy Tab A7 again available for debugging. At least this is solved.

However, after enabling developer options and USB debugging, I could not get the new S6 Lite to be available for debugging. In the last message, Ron said " Select Transferring files or Transferring images". Mine was set for transferring files so I switched it to transferring images. For some reason this made it work. Then I switched it back to transferring files and it still works.

Thanks for your help solving this issue!

1 Like