Bluetooth LE stop scanning when screen is off


I am currently developing an application to scan iBeacon. I am experiencing issue related to ble scan, whenever screen off, the ble stop scanning.

I know Google introduced a new feature. As of Android 8.1, unfiltered scan are blocked when the screen is off. I have applied the scanfilter, but it does not fix the issue on Samsung phone.

Is there any other setting that i have to apply?

Hi dan1582180597,
Can you share below information-

  • Sample application(source code)
  • Issue reproduction detail
  • Dumpstate log
    -Device information like OS/software version where the problem occurs

To get Dumpstate log files please find the following steps:

  1. phone > dialer > *#9900# > check seclog status
    => If seclog status is ‘enable seclog(currently disabled)’ > click enable seclog(currently disabled) > click ok on security notice popup > reboot device > go to the next step(2)
    => If seclog status is ‘disable seclog(currently enabled)’ > go to the next step(2)
  2. reproduce the issue
  3. phone > keypad > *#9900# > run dumpstate/logcat/modem log > copy to sdcard

Thank you.