Built fail error on new version 1.4.20

I am using the latest version of Watchface Studio, when I try to transfer the designed clock to the Galaxy Watch 5 pro , it gives an error message.
Please advise
Apologies for the poor English

If you are trying to publish this to Google Play Store
See this thread

Make sure you are creating an .aab file not an apk file in your build settings

If you are trying to sideload the watch face to your watch it may be a caching issue. Try closing WFS and then restarting your computer to clear any caches (not just shutting down and start ) See if it does it again.

Samsung Developer Relations

thanks for your response
I installed for the first time on a new Windows computer and even created a new watch face with just a digital clock.
When transferring to the watch, it gives this error message, but I installed the previous version and did not receive any error message.
I did as you said, but I still get the same error message.
How can I fix this problem with the new version?

Do you have any other tools that use ADB such as Android Studio.

You do have an AOD that isn’t blank correct?

You have ADB Debugging on and accepted it, you are using debug over WiFi selected and it connects and shows the connection IP address

Are you just trying to run on Device if so try building first that would associate a keyfile with the aab file that may be what is missing.

Samsung Developer Relations

i have only galaxy watch studio.

Galaxy Watch Studio is for Tizen and WatchFacestudio is for Wearos. You post in the forum for watchface studio = Wearos

Watchface Studio for WearOS.

But they wrote Galaxy Watch Studio.

excuse me
i have only watchface studio.
I apologize for the mistake I made
my english is nott good (I used Google Translate)

1 Like

You do not need to build to run on device with Watch Face Studio.

For the build error my guess is you have Android Studio or something installed already and your system is using that bundled tool instead of the WFS. If not try uninstalling WFS and reinstalling it.

Let us know if you get an error just running on Device.

Samsung Developer Relations

The error is fixed by changing the Regoin format to English in windows.
this is a bug