Error: "Notice: Build Fail" when opening WFS for first time

This is the error I get when I try to run a blank watch face on my GW4. When I first started WFS for the first time, I did import a custom font without having the file in the same directory as the project.

Since then, I have uninstalled WFS completely, downgraded to 1.0.11, deleted folders C:\Users\USER\WatchFaceStudio and C:\Users\USER\AppData\Roaming\watchfacestudio, and installed the 1.0.12 installation file again but still, the ‘build fail’ message shows every time I select my watch.

There is no information in the C:\Users\USER\AppData\Roaming\watchfacestudio\dump\main file.

It is really unfortunate that there is no error code or anything else to indicate what might be causing this error. Maybe someone else knows how to fix this?

EDIT: I have also restarted my watch and computer

This is probably the keystore error that some users that upgraded to WFS v1.0.11 got and it carries over to WFS 1.0.12

You basically have to create a new Keystore path and keystore. I think it will build fine after that.

If that doesn’t solve it let me know.

Samsung Developer Relations

Alright so I went to Build > Create new key > saved it at path ‘C:\Users\USER\WatchFaceStudio\keystore\keystore.jks’ > set all passwords to the same > key alias the default (key0) > validity default (25) > left everything underneath that blank. Yet the error still came up when running on watch.

Even when filling out everything in the keystore menu, I still got the error when choosing Run on Device. When building, I get another useless error:

I have no idea what to do

You get the blank warning with the Location is incorrect, that is not the keystore path, don’t use that. Location is the second text box which sets the location of the generated files when you select it you chose a FOLDER not a file so don’t open the folder and select it, select it from the parent folder.

When you run on device the first time after system start up it will connect but doesn’t recognize it. (I think it is a cache issue) restarting WFS will then connect and run on device.

Samsung Developer Relations

Ok, I think we are getting somewhere but I don’t think I am understanding you properly; I am still getting an error. I created a new keystore here:
and in the build settings I set the keystore here:
but now I am getting this error (keystore file exists, but is empty):
even though I definitely created one. It shows up in the dump file.

Ron can you maybe post a step by step setup showing where the keystore and build folders go. As well as what needs to be filled out when making a keystore file. I think this would help some of us greatly. I have used Galaxy Watch Studio to make faces for Galaxy watch 3 with no issues. But this is being a little frustrating to get it to build and run on the watch 4.

1 Like

In the project menu Location is where you want the binary files to be placed. GWS just put them in the workspace folder along side the project files but it was a popular request to have them in a separate folder.
This has to be a writable folder. I use something like C:\Users\username\WatchFaceStudio\workspace\project_name so each project has it’s own binary folder.

keystore path is the Java key store file type (.jks) for example

You get the empty error message because it points to a folder not the .jks file.

Think of the keystore as the information Play Store uses to find you if there is an issue. That is a requirement in almost every country.

Either keep the key alias as the default or one you can easily remember like mine is RonsKey. It is used for multiple developers in one project.

Samsung Developer Relations

But this is what I did before. This returns the same blank error. I will go through setting up a new project:

I create a new project:

I save the project in the directory that you use:


I press build then go to new keystore. I set the path and leave the default alias and set the passwords:

I set the build location to where the project file is located:

I build the watch face and I still get the blank error:

Your location path is incorrectly formatted path it has /build/project instead of a \build
project in it.


I have fixed this but it still shows a blank dialogue.

Oh trust me I have done everything under the sun to get this to work with ZERO luck. I have changed paths so many times to where my project build is saved and still get the Blank Warning of death that tells you nothing. I’m starting to think this program is broken.

I use Galaxy watch Studio for my Watch3 and never have a single problem builds every time and pushes to my watch every time.

I buy my girl the new watch4 and have to use this program to build faces and get nothing every time.

Why mess with something that’s not broken? I know they changed software but if the software isn’t broken why change it then? Leave it alone it works.

Please for the love of God will someone show us the correct paths to make this thing work?

Full path to save the project in WFS 1.0.12

Thank you, Sir but it still throws the warning message up after 100% build. And I
have the key store file in the right place as well.

I just don’t know why this will not build. I’m just trying to make a simple face first with a plain face and no AOD on it to get it to build and no luck.

Any suggestions on why this is happening?

I have uninstalled and re-installed the program, made a new keystore file, can’t understand why this is still not working for me. Does my build have anything to do with? I don’t believe it does. Did I not fill something out?

HI Rossp,

I looked at your log in the other thread and in this one and I agree and don’t understand what the issue is if it isn’t the Keystore file.

I hate to suggest this but delete the keystore folder restart your computer to clear any cache. Create a new keystore in a totally different folder say the users/username/keystore rename the main.log dump file so there is a brand new one.

When you create your keystore take screen shots of it and If it still fails copy the main.log
and send those in with support request. The WFS team may be able to find a solution hopefully it works and that isn’t necessary.

Samsung Developer Relations

I tried what you suggested above and no luck. I’m uploading the files you said to to see what they can find out.

I’ve uploaded the files.

The program won’t let me move the keystore folder location when I make a new one. I can make the folder where you said but it won’t let me choose that location to try it.

[WatchFaceStudio][6:02:54 PM][Socket.(KeyStore.js:127)] stderr: Generating 2,048 bit RSA key pair and self-signed certificate (SHA256withRSA) with a validity of 9,125 days
for: CN=Unkown, OU=Unkown, O=Unkown, L=Unkown, ST=Unkown, C=Unkown
[WatchFaceStudio][6:02:54 PM][Socket.(KeyStore.js:127)] stderr:

[WatchFaceStudio][6:02:55 PM][Socket.(KeyStore.js:127)] stderr: [Storing C:\Users\rossp\WatchFaceStudio\keystore\keystore.jks]
[WatchFaceStudio][6:02:55 PM][Socket.(KeyStore.js:127)] stderr:

Looks to me like it can’t be written and there is a blank error message hence the blank build error box.

Lets make sure
you installed WFS for one user only and that is installed in C:\Users\rossp\AppData\Local\Programs\WatchFaceStudio
and when you created a new keystore it was
C:\Users\rossp\WatchFaceStudio\keystore\keystore.jks and you used the browse option to select that location and make the file name keystore.jks no spelling or uppercase changes

Finally when you create they keystore file there is a few blank spaces that do not show and you have to tab or scroll down for them. I am wondering if they are blank it can’t completely write the file.

Samsung Developer Relations

Hey Ron,
Yes it’s installed for me only and it’s the location you stated about.

My folders for the path are as follows-


inside the project_test folder is the file test for the watch face build.

The keystore path is the same as yours


Now I wondering does EVERYTHING have to filled out when making a keystore file?

I ran the build with this set up and still got the blank warning message box.


As far as I know, Yes everything has to be filled out but if it is only for your use it can be silly data. I am thinking you may have missed something so it can’t write the keystore.jks information.