Error tpk not valid

hope someone can help i have used this watch face before trying to load it on my Active 2 i get the error
" Existing tpk is not valid for this device Rebuild the tpk and try again "

i have also tried to load a sample watch face with the same error
Mac Version 2.0 GWS
Using Tizen Studio to connect to GWS

any ideas would be great Thanks !

Hi @kel1594354206,

Try following steps, it may help

  1. First, keep backup of your all .gwd files (not .tpk files or others) from \GearWatchDesigner\workspace directory into another directory.
  2. Remove everything from \GearWatchDesigner\workspace directory and restart your computer .
  3. Now, copy all your backup .gwd files and paste them into \GearWatchDesigner\workspace directory.
  4. If an older version of this watch face is installed on your watch then uninstall it.
  5. Start GWS and try to build your project and Run On Device.

Let me know if it works.


Thanks for the reply Yes i tried everything you posted same result i also connected via sdboverbt and got the error "Fail to connect and launch " re did the certificates not sure what to try next any ideas Thanks

Hi Kel,

Can you build and install one of the GWS example watch faces?
If not then did you accept the RSA Encryption Key when you first tried to install a watch face on your watch.
There is a lot of problems with connecting on Catalina as the RSA Encryption Key permission does not last very long.
We can help you with if that is the issue.

Samsung Developer Program

Thanks Ron

I have tried the sample faces i get the same error
yes i did get the RSA Key hen i connected through Tizen
when i connect with Tizen it goes to about 80% then i get the error
when i connect with sdboverbt i get the error right away " failed to connect and launch "
and i have tried for days to connect just over wifi
restarted Mac
phone and watch many times
debugging is on
i have no other watch faces on the Active 2 just stock ones
in folder Workspace i only have the one watch face 1 tpk file and 1 gwd file

not sure what to try next any help would be great !!!Thanks !!!

I think you accidentally hit the x instead of the check mark for the RSA key. It will never ask again if you do.

in the User account folder there is a hidden folder .tizen and in it are two files sdbkey and rename those and then try to connect via Tizen Studio Device manager. Be sure your watch is on a factory installed watch face and you are keeping it alive and select the check mark. You do not need to select the don’t show again but it won’t hurt if you do.

Let us know if that works.

Samsung Developer Program

Then using GWS put your IP address in the dialog box and connect and see it it then completes the .tpk install.

Thank you Ron i will try that Where would i find the User account folder Thanks

Great News for me i did get it to work i uninstalled GWS Version 2.0 and installed Version 1.81 Connected with Tizen Studio and It works Thanks to everyone for the help !!! especially Burr Zoo Thanks !!!

It should work with GWS 2.0 but if you have it working I’d keep using 1.8.1.

Samsung Developer Program