Mac Cannot connect to GWS2.0, reinstalled GWD, got issues

Hi All,

I managed to publish a few watch faces for quite some time. Got busy, pandemic and took time off. I came back, updated to GWS and created a watch face.

While trying to upload it to my watch:-
-My phone couldn’t connect to GWS. Tried direct wifi connect, troubleshoot, debug, sdboverBT, all those but to no avail.

  • Re-installed GWD 1.8, my phone CAN connect but halfway another problem surfaced - Kindly see attached!

Thanks for the help in advance.

Screen Shot 2020-06-04 at 9.21.22 PM|459x275

An RSA Encryption Key is necessary for transferring data to and from a mobile device. It was strengthened because of 2019 GDPR and other country stricter privacy laws.

Everyone is having a hard time connecting to Catalina it is because there is a very short time frame to accept the RSA Encryption Key on the watch especially Catalina. Luckily you only have to do it one time.
Here are some suggestions that might help.
set your watch to a factory installed watch face apparently it keeps the acknowledgement face longer.
Use your IP setting from the watch do not try to search for it.
Watch your watch and keep it active when you first try to connect
When it connects select yes and do not show again (even though it won’t show again)
If it doesn’t appear.
Hold down the home button (bottom button) for about 15 seconds until it says rebooting
Restart your computer as well
Start GWS and try to connect again, be very observant for the RSA Encryption Key acknowledgement

Still no luck? If you are on windows (10 for example) go to your “Users”-folder of the logged in account and search for a “.tizen”-folder. There are 2 files in it called “sdbkey” and “sdbkey.pub”. There is an equivalent for Mac but I don’t know the exact path.

Try again

Still no luck?
you need the iOS version of Tizen Studio for the sdb.exe You can download the Tizen Studio SDK or contact tech support and ask them to send you the Mac version of SDB.exe. This file comes with GWD but apparently isn’t the latest version necessary for Catalina.

That has proven to work but even it may take several attempts.

Ron
Samsung Developer Program

Hi Ron,

I did everything but still no luck.

I clicked the link you mentioned and brings me to Samsung Service Centre. Live chat with an agent and told me to Factory reset my watch! I asked him why should I do that and gave me funny answers.
Anyway, still no luck with this…

I am using an iMac and OS is High Sierra, not Catalina

I tried downgrading to 1.8.1 GWD. Managed to connect my watch but the below error appears:-

Screen Shot 2020-06-08 at 7.57.46 PM

Pls. Help. Thanks

I’m really sorry about that bad link I typed samsung.com/support and not https://developer.samsung.com/support by mistake.

Generate a new Distributor Certificate I think you may already have accepted the RSA Encryption key. I’ve seen a couple users that said they updated the Galaxy Watch and needed to create a new distributor certificate.

Again let me know if a distributor certificate isn’t the problem and I’ll tell you what to delete to force an RSA acceptance to start over.

Hi Ron,

Updated again from 1.8.1 to GWS 2.0. Generated a new Certificate. Tried connecting using my watch. My phone (sdboverbt), searching both IP of Watch and phone. Still no luck.

Hi Ron,

Managed to make it work at 1.8.1. I will stick to this one first and will eventually update.

Thanks for the help.