For the life of me, can't add new ttf font to Mac version

On Mac Catalina,
Have tried both Galaxy Watch Designer 1.8.1 and Galaxy Watch Studio 2.0.0
No matter what technique I have used (adding fonts to font folder, using the resource to add font, adding to Mac proper) I can’t add a new font to the app.

I even tried renaming the font file to WatchFontName.ttf!!

Has anybody succeeded on Mac Catalina?

On a Mac, the font must be installed before it can be added to GWS. To install the font, double-click the font in the Finder and click Install Font. To make the font available to all projects in GWS, add the font to the \\Galaxy Watch Studio\font directory.

Ron
Samsung Developer Program

Ron,

Yes, this is exactly what everyone/every site says. It just doesn’t seem to work. IF this worked , all the ttf fonts from Mac would be available, They just aren’t. We only see a bunch of Watch.... fonts
Has ANYBODY done this successfully???

ALSO: What do you call \\Galaxy Watch Studio\font
That’s not at all clear where it is.

Jacques

HI Jaques,

That will teach me to copy from the FAQ I believe the folder is still Galaxy Watch Designer on Mac as it is on Windows. If you can’t find the Folder on your Mac let us know and if no one posts a screen shot of how to find it, I’ll have one of our support team give me a screen shot and I’ll post it Monday.

GWS will only see fonts that are in that folder or ones you add manually to the project.

Ron
Samsung Developer Program

This is ALL folders I have. I have created a folder named font everywhere and added the .ttf file there AND the OS. I tried renaming the file without a space.

Ugh

`lax@iMac GalaxyWatchDesigner.app % tree -v -L 3
.
├── Contents
│ ├── Eclipse
│ │ ├── GalaxyWatchDesigner.ini
│ │ ├── artifacts.xml
│ │ ├── configuration
│ │ ├── p2
│ │ └── plugins
│ ├── Info.plist
│ ├── MacOS
│ │ └── GalaxyWatchDesigner
│ ├── Resources
│ │ ├── OpenSourceLicenses.txt
│ │ ├── ReleaseNotes.txt
│ │ ├── [GWD]Guidelines\ on\ Connecting\ a\ Watch\ device\ to\ GWD.pdf
│ │ ├── font
│ │ ├── mac.icns
│ │ ├── res
│ │ ├── sample
│ │ └── template
│ ├── conf
│ │ ├── font.sh
│ │ ├── log.conf
│ │ └── updateURL.conf
│ ├── font
│ │ └── pirulen\ rg.ttf
│ └── tizen
│ ├── keystore
│ ├── moonphase.db
│ └── tools
├── font
│ └── pirulen\ rg.ttf
└── temp
└── pirulen\ rg.ttf

18 directories, 15 files`

Any luck with the dev team giving us a real screenshot?

Here are 2 screen recordings. The first is adding a font to the Mac system. However, several version ago in GWD/GWS you install fonts directly. The second screen recording shows you this.

Hope these help

Ron
Samsung Developer Program

I guess I need to file a bug report. Repeated the exact steps. No longer works in either 1.8.1 nor 2.0.0 on Catalina 10.15.4

I bet it is the fonts then. To test it make a copy of one of the Samsung installed fonts and see if you can add them etc.

Ron
Samsung Developer Program

I believe you have won this argument :smiley:

That font (and all version of it on the net apparently) just don’t work. I tried another one and it just worked first time.

No sweat , only a week lost hahaha

Thanks for your patience.

Jacques

Hi Ron! I’m Guillermo from Faster watchfaces I have started to develop some faces and I have the same problem, I use the MacOS Catalina version!
I leave my video here so you can see that I follow the steps and it doesn’t work …


I have tried this same font in windows and it works!

thanks for the great work you do!

Try adding the font to the \\Galaxy Watch Studio\font directory.

My understanding is that Windows TTFs work on both Windows and Mac but Mac TTF’s do not work on Windows. I am wondering since you aren’t alone if you have a Mac only TTF and that is an issue (bug).

One other thing to try… rename it .TTF no .ttf that was an old bug and it may have came back.

Ron
Samsung Developer Program

Hi Guillermo,

Let me cut to the chase:
Some fonts just don’t work on Mac version (in my case on Catalina). I couldn’t find the reason, but I had to resort to similar fonts from somewhere else to achieve my goal. I know it sucks!. The whole discussion about directories etc are a dead end.
Might be wrong place … but I had better luck with WatchMaker, although really complicated to use on Galaxy Watches. But it seems more robust and better tested. The designer works straight from the phone. Just can’t figure out how to switch from day to night mode :smiley:
Jacques