Galaxy Tab S7 BLE LE can't be connected by Windows 10

My issue is very similar to a reported issue here with some difference. Bluetooth LE issue after security patch update (Level 2020-11-01)

I have a WPF app (BLE Gatt Client) running on Win 10 that pairs and connect to a custom BLE Gatt Server running on Samsung Galaxy Tab S7 (SM-T870). We have tried Win 10 version 1909, 2004, 20H2 and found that the WPF app is unable to connect to the tablet after pairing.

And we can actually see the same result using Microsoft sample app (Bluetooth LE Explorer) with sample Android BLE APK (Simple Gatt Server ).

Step to replicate:
On Win 10 system, download Bluetooth LE Explorer from Windows store.
Build and install Simple Gatt Server from here
Pair S7 to Windows from Windows Bluetooth Setting page.
Launch Bluetooth LE explorer and click on ‘Start’ button.
Wait for the enumeration to finish, or directly hit the ‘stop’ button once S7 is shown.
Click on S7 device tile from Bluetooth LE Explorer.

Bluetooth LE Explorer is either connecting indefinitely to the tablet, or shows a ‘Device unreachable’ failure.

Same as the issue reported here, if I OFF the wifi on S7, the connection will succeed and all the BLE services and characteristic will be shown on Bluetooth LE explorer. But once Wifi is on again, the connection will get disconnected after a while.

But unlike the other link, we tried OFF the Hotspot 2.0 on S7, it doesn’t help on the connection.

S7 was previously on Android 11. Previously it was on Jan 2021 security patch. I have updated it to 1 April 2021 security patch and the issue still persists.

Please kindly help to look at the issue.

Hello Angel,
Welcome to the community!
You may report here with proper logs to get the issue further analyzed.
To get dumpstate log please follow the below steps:
a) Immediately after issue reproduction, dial *#9900# and if the Debug Level is Disabled/LOW, tap to select MID. This restarts the device.
b) Again dial *#9900# and press “RUN DUMPSTATE/LOGCAT/”
c) When it is finished press “COPY TO SDCARD(INCLUDE CP RAMDUMP)
d) In the main folder of the device file system, there will be a new folder called “log”. The log file should be there.

Thank you.

Hi @ssaha ,

May I know how to register for zendesk account? I can log into but not

Thank you.

Can you access this link?
I guess, you’ll be able to submit a request with just logging into your Samsung Account through that link.

Hi @ssaha , Yes, I am able to access the Dashboard. Just to check, the log is pretty big. Do I need to ‘delete the DUMPSTATE/LOGCAT/’ first before I repro the issue and ‘Run DUMPSTATE/LOGCAT/’?