Galaxy Watch Studio Distributor Certificate


i’m new in Galaxy Watch Studio 2.0.0 and have a problem to run new designs at
my Galaxy Watch Active 2:

  • i have created a Author and a Distibutor Certificate without problems
  • I build the project
  • if i run on device i always get a message “The device has not been registered…”

What can i do?
What is wrong?


I am going to assume you have your watch in developer mode and have debugging enabled.
That you were able to connect in order to create the distributor certificate

The first time you try to side-load the app on the device it will show a show an RSA Key that has to be accepted.
You must have acknowledged the RSA key screen on the watch (allows for data transfer between the watch and your PC). If you missed this screen or don’t remember if you acknowledged it, disable Bluetooth, Reboot (hold down the power key until it says rebooting not power off) the watch, and, after the message that shows your watch has reconnected to the network disappears, wait 30 - 60 seconds, then try connecting again. Keep your watch nearby and active as the RSA key screen displays for only a few seconds.
If you have a factory watch face it shows a bit longer but it still goes away in 15 seconds or so. If you don’t acknowledge it the OS assumes it was an attempted hack and won’t show it again until you reboot.

You may need to repeat these steps (increasing the wait time after Wi-Fi has connected) to get to and acknowledge the RSA key screen.

Samsung Developer Program

Hi Ron,

thank you very much, the problem is solved, I just had to turn off bluetooth and everything worked!


Happy too early:
The transmission worked, but the hands of the clock stand still!
When transferring a sample, it works …

i found it, settings for hands are now correct :slight_smile: