Hiding "No Event" on next event complication

I want to find out how to hide the no event text on this complication. Both the basic “Next Event” complication and calendar’s “Event” shows a text when there is no event for the day as shown here.

Basic “Next Event” complication

Calendar’s “Event” complication

Is there a way to hide this text?

if not then is there a way to center it? Because my usual layout is like this and the no event text ruins it.

Select the text element within the complication and try selecting center alignment under text appearances

I’ve already set it to center. You can see that it is on the picture with the test event so unfortunately it doesn’t work and the no event thing still persists.

Hi what if u used left align instead? Everything to the left? If yes just adjust so it “looks” centered

Changing it to make it alligned to the left and adjusting the position wont fix it. The title and text are of different lengths.

Then from what i know, i unable to give anymore tips regarding this. Unless there is a tag that tell u got event or not

Hi, i tested on my gw 5 pro.
No issues u missing something?


What model is yours?

I’m on a galaxy watch 6 classic.

Are you centering it on the text and title or the complication itself?

Hi , normal alignment no work around. Just put the complication in the centre normally

U using google calender?


Only thing i can think of is that we using different watch model so different outputs…maybe

yea i’m using google calendar

Does anything seem out of place on the properties of both of these elements on my side? Maybe I’m doing something wrong

i see that yours has a hidden image? as the element has a image but it not showing it your canvas.

Yeah i had it way off on the side outside of the actual display since I can’t seem to figure out how to remove the calendar logo without it being the image and throwing it out the display. Which layout did you used?

hi, if you didn;t edit the layout properties on the right, the watch will choose the default anyways.
which for your watch I am not sure, for my the default is the title and text only layout.

just in case can you edit the layout that has title and text only. do the same as you did for your current layout.

what i mean is you edit only the image type layout. but the watch might not use that instead in try to select one from all that is shown on the right.

only way is to edit all of the layout. or remove them unwanted

Still doesn’t work. I wonder what’s the difference between yours and mine. Hm

difference is the watch model and wear os version?

You’re right. Oh well, I guess I’ll just give up and try another layout.

Hi @scylious forgot to mention also the difference is I force watch to select only layout I wanted, but to make it simple for you I decided to text by trial and error instead of forcing to one layout. (removing other layouts) the way i usually do.

and I found out you need to edit two layouts.

one is this

the other is also your previous layout

the reason that as i explained the watch will choose layout from all that is enable…meaning layout 1 to 5 anyone.

so for no event (it choose layout 2)
but if you got a event (it choose layout 4)

try this should work.

for me i did this that why the difference

Read this

Oh wow! Thank you! That works wonderfuly.