BUG: LONG TEXT complication / next event / AOD with latest GW4 update

Hello Everyone,

with the latest update of the Galaxy Watch 4 (R875FXXU1EVA8), the “LONG TEXT” complication with “Next Event” provider (calendar events) seems to no longer work.

In case of an event, the complication displays a blank field instead of showing the next appointment as usual.

Software versions:

Watch Face Studio: 1.0.12
Galaxy Watch 4: R875FXXU1EVA8

3 Likes

I thought that it was a bug from day one.

I’m updating my GW4 now I can give it a try.

Ron

It worked for me just fine on MD111. It showed the time not the event. Make sure the user selected Calendar and not Outlook on his phone.

Ron

HI Ron,

there is no such complication on MD111.

Try to see MD286 or MD289 on Play Store to better understand.

This is the complication that displays the event / appointment title from the Calendar (LONG TEXT).

BEFORE:

NOW:

Thank you

Working fine for me after yesterdays update. One problem is that the new complication icon is dark-grey. I really thought that 600 mb update will finally fix most of the problems with icons resolutions etc., but nothing changes. Only good thing is that steps shortcut now works correctly & weather icons are now looking better. Still no heart rate complication support. Google assistant coming “soon” feels like a joke…

screenshot_ 8-08-27

Edit: Cleared caches & connections
Now it doesn’t work, using only Google Calendar. Definitely another beautiful bug that will make our lives more enjoyable. At least the steps shortcut works…

Edit 2: Same with SHORT_TEXT complication

2 Likes

I confirm the bug. Before the firmware update everything works fine (watch face studio 1.0.12) after show correctly “no upcoming events” if there are no events in calendar, but the text disappear if there is an active event.

1 Like

I also found another bug after the latest GW4 update …

The AOD does not update until the screen is activated.

3 Likes

Can confirm too, already getting bad feedback…

1 Like

I confirm. Most of 3rd part watchfaces has problem with AOD. Problem is in onTimeTick() function. More here:
Some older watchfaces may not work correctly after latest GW4 system update : WearOS (reddit.com)

1 Like

I can confirm too that the AOD does not update until the screen is activated on all my models.

I confirm the next event bug. I can’t trust Samsung anymore

For both MD286 and MD289 I had to tap on the complication (a couple times) but eventually it asked me to allow permission to access the data and it loaded saying No upcoming events. I set an event in Calendar and that showed.

On MD111 I changed the complication to Calendar and it asked for that as well.

For MD111 I changed the complication to Reminder and it did not ask for that permission (Or I don’t remember it asking).

Ron

I didn’t understand, I think those may be cross platform emulators. I couldn’t duplicate this (If I understand correctly) with Matteo’s watch faces.

@Matteo_Dini can you or Raydesign tell me more.

Ron

I’m talking about update of time on AOD. Doesn’t work. Time is updating after watch wake-up from AOD to active mode. This is not problem WFS but is problem of last big update GW4
Sorry for my english :sweat_smile:

1 Like

Hi Ron, try restarting watch / clear wearable app caches. It wont work. It’s working for you the same way it was working for me. It’s working because wf is using temp data.

Tomas

1 Like

Hi @r.liechty_SDP,

I think the guys above have already explained everything to you.

I am already receiving some reports from this side … Including negative feedback from the store of course.

Other feedbacks:

Thank you

I can confirm the bug where AOD does not refresh the time.
This should definitely be a priority fix!

I can also confirm the bug where “Next Event” icon appears dark-gray, making it almost invisible on dark backgrounds, especially since most of us implemented it to our designs when it was white (you know, like ALL other icons).

UPDATE:
The next day after updating, Next Event indicator with “short text” no longer works - can confirm bug.
Right after updating it seemed to work fine. The next day however, it was showing “None”, even when there are events for today, and after changing to a different indicator and back to Next Event, it’s completely empty, without text or icon - staying like this no matter what.

Hopefully Samsung will manage to release an update which doesn’t create new major bugs… maybe next time? :crossed_fingers:

2 Likes

Yesterday, I set up SHORT_TEXT and LONG_TEXT calendar complications on about three dials. The complication did not work on either spot. I woke up this morning and strangely both SHORT_TEXT and LONG_TEXT are showing “NONE”.

So I tried to set an event an hour later - event name - TEST 3. But the complications still show “NONE” so I tried to re-select the calendar application for the complication. The watch started to freeze a bit and both types of complications are now showing nothing - they are empty blank spaces as on @Matteo_Dini image.

@enkei_design Can you try to set an event and repeat the steps I did?

Thanks

I did your same tests and got the same issues.

1 Like

I also tried to create a new event and nothing was displayed. I even used different calendars … googel calendar and Samsung calendar. Both times without success.