I can't debug my Galaxy Watch 6

I can’t debug my Galaxy Watch 6 with a PC or a phone - I’ve watched guides and filled in all the fields correctly - what could be the problem?

Hi, what do you mean u can debug. U mean cant connect to your watch in wfs?

Pc is on lan or wi-fi?

More on what u tried and error u Got?

Hi, yes cant connect watch in wfs. PC lan but I check via mobile with same Wi-Fi and it still doesn’t connect to watch. Will it not work via PC Lan?

Hi, advisable and easier to connect via having both on same wi-fi band. You may want to try calling adb from command line.

Read this thread

I tried through the console but something doesn’t work out for me.

Hi, i see you did adb pair <…>

Please try e.g

Adb pair

No need the “<” and “>”

Adb: The name “Adb” is not recognized as the name of a cmdlet, function, file script, or executable program. check for correctness
the ability to write the name, as well as the presence and correctness of the path, then repeat this event.
line:1 character:1

  • adb pair
  •   + Category information: ObjectNotFound: (Adb:String) [], CommandNotFoundException
      + FullyQualifiedErrorId: CommandNotFoundException

Sentence [3, General]: The Adb command was not found, but exists in its current state. By default, I’m telling you that Windows PowerShell doesn’t load commands in the current direction. If you are sure the command is reliable, enter “.\Adb”. To get call details, use the command “get-help about_Command_Precedence”.
PS E:\9343b833-e7af-42ea-8a61-31bc41eefe2b\WatchFaceStudio\tools\window>

thank you it worked like this - .\adb pair

but now the watch shows pairing with the PC but watch face studio does not see the watch anyway

@dimak U should do adb connect also.

.\Adb connect x.x.x.x:port

After the pair

Please retry all steps carefully.

1 Like