My Galaxy Watch 4 is not connecting to WFS


I am having some issues with testing watch faces made with Watch Face Studio on my Galaxy Watch 4.

I have followed all the instructions: activated dev mode, enabled ADB debugging and Debug over wifi option. But still, when I add the IP that shows on the debug over wifi option into WFS, I can’t see the device in the connected devices list.

Also, I am connected to the same wifi network with my pc and with the watch

Any help would be very much appreciated.

Was Watch 4 connected to WFS successful?
I also received Watch 4 today and am trying to connect, but it’s not working.

1 Like

Did you turn off Bluetooth on watch, I rebooted pc and watch after setting debug options and entered IP and it connected first time I got a prompt on watch to enable.

Did you check all the developer menu settings are correct ?

I enabled debug over wifi and adb debugging with the small blue circle to the right.

I tried on two different networks, PCs, both methods - WIFI and BT via Phone. Nothing works. Had ECONNRESET error on first run after installing Watch Face Designer. Tried also manually add firewall rules.

This is what helped me to find my device on the list: