Watch connects to ADB but not Watch Face Studio

I apologise if this has been answered before, I didn’t see it when I looked. I have a GalaxyWatch5 40mm. I’ve struggled to put a watch face I created on it. Using information I found here I was able to pair my watch with my PC through ADB, but I still cannot get Watch Face Studio to see it at all.

One thing I am wondering, should ADB be in the same folder? Currently both are in Program Files in their own respective directories.

Any ideas?

I dont know, maybe this could help:


That is a known issue. If you have more than one ADB then Run on Device doesn’t always work from Watch Face Studio. The WFS team is working on it but the commands WFS uses use tools relative to the adb app.

@Peter had the thread that tells you how to launch adb from the WFS installation.

Samsung Developer Relations

Thank you both, been messing with it and still haven’t gotten it to work, but I think I realized why. After reading through many more posts I noticed this one WFS wont connect to GW5? (Solved) - #10 by r.liechty_SDP and I think that is my issue.

My PC is ethernet cable only it doesn’t have a wireless network card. So I am on hold till I get my Laptop back and will install WFS on the laptop and it is straight wireless connection so that should guarantee that both watch and laptop are on same wireless connection.

I’ve only connected to a watch from an ethernet computer connection one time. But I rarely try it. You could try this connecting ADB from your Computer to Watch instead of the other way around.

Using File manager copy the address where you installed adb by default
(copy the address as text from file manger using right click on the address bar)
Open a command prompt
navigate to the folder address
cd C:\Users\USERNAME\AppData\Local\Programs\WatchFaceStudio\tools\window
Then type
adb connect 192.168.x.x:5555 (where 192.168.x.x is your watch’s IP address).
It may take a minute to connect or give a failure response
If you get a rejected error or something check your watch debugger settings.
Try in developer options to revoked permissions and force new acceptance. do the connect again.

I’m not sure if the Port is different for Ethernet than WiFi but you can try.

Samsung Developer Relations