New Computer, Won't install GWS

Hello all. I just got a new computer, and the screenshot says which version of java i am running, but when i go to install GWS, it pops up that i don’t have have it installed. Also in the screenshot, I have tried all the versions in the download window. I could use some help. I did however have it installed before but it was doing some crazy things, like running very sluggish. wierd stuff was going loading a face and So I tried another java version. During one part of the running sluggish and wiered stuff I got another popup. 2nd screen shot. Anyway it won’t install at all. aHelp would be appreciated.
Thanks in advance

Hi @mar1582925282,

“Java was started but returned exit code=13” this error usually arises for the reason below,

  • You are using 32bit Java version which is incompatible with GWS latest version (64bit). So you should uninstall 32 bit java first and then install Java 64 bit.

If you don’t want to uninstall 32bit Java from your system then you have to keep both Java versions in your system and set the environment variable accordingly but try the above first and let me know if you want to keep both.

You may also look at System Requirements and Required Java Version for Galaxy Watch Studio.

Regards,
Azad

1 Like

Azad as usual is spot on.

The Java version you need to download is the x64 version not the x86 version be sure you have the right one and the right path settings.

Ron
Samsung Developer Program

1 Like

Double-checked the version of Java I had after seeing this thread and noticed that I too only had the 32bit version installed.

Think this is because the Java download page recommends you use the online installer rather than the offline one, but then if you use the online one it will install 32bit.