GWS Install & Launch Error

I have an issue when i have to Run a Watchface on my device, when the Bar for Install & Launch comes up it Jumps to 40% then 60% and then immediately dissapeares without loading the watch face on my Device, Galaxy Watch.
This only happened when i installed GWS 2.0, before that when i had GWD 1.8.0 it uploaded to my watch just fine.
Below is what i mean by the Install and Launch Bar that onlyu installs to 60% the Dissapears

Thank you

Does it give you any error message or a java error or a distributor certificate error
Have you tried completely shutting down your PC (not restarting)
And then starting all over again, more than likely if the fonts you are using are bitmaps then… you might have to put them back again
Try shut down and start (before you do anything else)and see if it works

Hi Malcolm
I have Shut down and restarted my PC with the same issue
There is no Error Message that pops up
the Bar pops up runs to 40% then 60% then it disappears as if nothing happened
I have completed the Distribution Certificate so i dont think its that
Maybe its Java, also im not to well versed on Java


Along with what Malcolm said.

If this is just one watch face…
Check the AOD to be sure the OPRis not close to 15% sometimes it won’t install if it is above 10% in GWD
Go to settings - About Watch - Software - and tap 5 times on Software Version to enable Developer Options
I’ve also heard of this with custom fonts but if it ran before that shouldn’t be an issue.

If you can’t do a sample watch face then check the standard connection issues, debugging on RSA key accepted etc.

Samsung Developer Program

Hi Yohan
Try another watch face and see if it gives you the same problem
That way we will know if it is that particular watch face or something with the system

i have tried other watch faces and they do the same, but on the last watch face it gave me the below Error Message.

This looks like the RSA encryption key issue. Did you update Windows 10 recently? Hold down the home key (bottom key) for about 15 seconds until it says rebooting.
Restart (not just turn off and on) your computer to clear any caches
Set your watch face to one of the preinstalled watch faces

Next time you go to connect to the Watch observe it carefully when you do. An RSA Encryption Key will need to be accepted. Once you do that the watch faces should load on your Watch as before.

If you don’t see the RSA key after rebooting you missed it, it only stays on for a few seconds. If you miss it, it only stays on for a short time

Samsung Developer Program

I Need to apologies to you guys, it is working again, but thats because i saw that my Memory on my Watch was full, i deleted a few Songs and Watch faces and now its loading again
Im so sorry for wasting your time
Thank you so much for all your responses and help

Thanks for letting us know the solution. I’ll add it to my bag of tricks to check for !!

Samsung Developer Program