New watch face doesn't show on phone (Galaxy wearable app)

This one worked. After uninstalling everything works. :slightly_smiling_face:

Matteo,

Can you find out if this is Pixel watches or Samsung Watches if Samsung are they Watch4 or Watch5?

Ron

I tried isaacok0919’s advice on watch5pro:
after uninstalling and reinstalling the watch faces I uploaded prior to the problems (and deleted them since) reapeared, but not the ones I tried to upload in the last few days (run on device).
And still, when I try to upload the new watch face, it doesn’t appear in downloaded section.

Thanks for your workaround. I’ve confirmed that Wear OS by Google 1.3.119 (released in 9th Nov) caused this issue at least on my Pixel Watch. Reverting to older one may fix this issue on Galaxy platform as well.

@r.liechty_SDP

From the feedback I received by email, this issue was found on both GW4 and GW5.

On the Pixel Watch, I only had complaints about the customization.

Can confirm this on Pixel Watch. Looks like this is wider issue - maybe some core play services / wear os implementation error.

Watch > Play Store > Manage apps > Wear OS by Google smartwatch > Uninstall (only updates will be removed)

From what I can gather this is a Play Store issue and the solution that @isaacok0919 suggested does work. But I did report it to support and it was passed on the relevant teams.

It is a very bad user experience especially for new Smart Watch users

Ron
Samsung Developer Relations

1 Like

After following @isaacok0919 instructions,
I managed to get all uploaded watch faces into the Downloaded section of the phone.
But - I have to do this now everytime I create new watch face
(so after I creat watch face, I need to uninstall and reinstall Wear OS).
And given the fact, that I have to set the downloaded watch faces again after reinstall,
this really is a cumbersome and bad user experience.
Thank you again for reporting it!

I hope the reference teams release a fix very soon.

We are receiving tons of complaints and emails about this issue and every day posts appear on various social networks about this issue.

Greetings.

Today I’ve tried updating to newer Wear OS by Google 1.3.119.489435902 (released in 18th Nov) on my Pixel Watch, and then I’ve updated Pixel Watch App (on the Phone) as well.

Although I just did adb-ing only one newly built watchface to Pixel Watch, the issue seems to be fixed by that version. That newly built face came up in the watch face list of Pixel Watch App normally. And editing complications, changing colours, those basic functions also look normal.

Best Regards.

today an update for Wear OS by Google Version 1.3.119.489435902 for Galaxy Watch 5

Hi,
How do you install this update for the GW 5?

Thanks in advance,
Doug

I seem to have the *902 version but watch faces are still now showing up. Do i Have to do something else?

On your Watch > Play Store > Manage apps > Install Updates

Ron
Samsung Developer Relations

1 Like

Thanks, its updated. but watchfaces are still not showing up in app on phone.

A new software update for GW5 has been released:

R920XXU1AVK7 / R9200XM1AVK7

Some users wrote to me that now they can see the Watch Faces in “Downloaded watch faces”.

Can anyone who had this issue confirm?

I’m getting negative feedback on the updated watch face. users complain that they cannot set up the watch face using the phone. I tried to send the dial to the phone myself, I could not set it up either. The loading screen opens and then closes. with other (old) dials everything is ok.

I tried to create a watch face from scratch. same error.

tried to test partially. a few settings - sending to the phone - ok - added a few more settings - sent to the phone - the error repeats.

@DKWatch

On your watch
Open Play store app
scroll down to manage apps
Install updates

one of them is Wear OS by Google that is the issue.

It is not a forced update that is the issue it needs to be manually done

Ron
Samsung Developer Relations

I updated everything that was possible on the watch, on your recommendation. But the error remains.

I suspect that the error is due to the wearable application. version 2.2.53.22101061. In the galaxy store, the update was from November 21st.

in PM version 2.2.50.22072061 dated 26 July. Removing wearable, resetting the clock and installing the old version from the PM does not work, because at startup it asks for an update.

ps comments about the styles customization error also appeared starting on November 22nd.

Galaxy watch 4

R860XXU1GVK4 / R860OXM1GVK4