New watch face doesn't show on phone (Galaxy wearable app)

Hello,
I have generated many watch faces with WFS. And until two days ago, all was fine.

But now when I create a new watch face and perform “run on device”, it shows on my watch, but not in the app on my phone.
Even if I “run on device” some of the watch faces I created before this bug started to happen, they don’t show on my phone (in the app) either )(but they show on the watch).

As all complications are defined on the phone - I am not able to do that, as wacth face is not accesible on the phone…

What has changed or what am I doing wrong?

Devices:
WatchFaceStudio 1.3.12
Watch 5Pro
S22

1 Like

Hi.

From yesterday, I have similar issue on my Google Pixel Watch and WFS 1.3.12 (and 1.3.8 beta). Newly built APKs work fine as expected (via adb installing) on my Pixel Watch, but those watchfaces aren’t listed in Pixel Watch App on the phone. So after reading your post, I now think that might not be the Galaxy specific but Wear 3.0 widely…

I have the same problem today. when I create a new watch face and perform “run on device”, it shows on my watch, but not in the app on my phone.

It is used.

Galaxy Watch 5
Galaxy S10
WFS 1.3.12
Wearable App version 2.2.53.22101061
Galaxy Watch5 Manager version 2.2.12.22110951

1 Like

So it is not an insulated case.
I am asking all of you, who get same issue, to post reply here, so that we get attention of the community and hopefully quick fix of the problem.

Exact same issue for me.

Devices:
Wacth Face Studio 1.3.12
Watch 5 Pro
S21 Ultra

I think there is something wrong also with Wearable App. I am getting some feedback from users who have the same issue even with watch faces created with previous version of WFS.

Probably. My troubles started while I still had WFS 1.3.08, I upgraded hoping this is a version issue…

Not a version issue. In WFS 1.3.12 it’s the same thing.

Try this,

On your phone change your language to something else
Make your watch active
change your phone language back to normal

I think this is the same bug that breaks customizations and my guess is it is a caching error.

Do Not reinstall software on GW4, for fear of the bricked watch

Let me know if that helps,

Ron
Samsung Developer Relations

Thank you for your advice,
however - it didn’t resolve the situation.

I changed the language on the phone (made SLK default), checked that it connected with the watch (the name of the day changed to that language), then changed back,
tried to “run on device” new watchface, it uploads to the watch, not to the phone.

1 Like

Thanks for the info. I can’t duplicate this myself but obviously there is an issue.

The customizations was the same sort of issue worked on watch but not on Phone and very few people had the issue.

I doubt it is WFS more a Wearable App issue. I’ll report this as a bug anyway.

Ron
Samsung Developer Relations

1 Like

Thank you for this.
You say that you cannot duplicate the bug I will give you more detailed timeline:
-I have been uploading (run on device) many watch faces in the past month (you know, new toy)
-3 days ago I updated one old watch face and uploaded it (run on device)
-when the updated app showed on the phone, I got message (written by memory, could be a bit different): “you need to update the watch face (name of the watch face” - OK or cancel
-when I pressed OK, I repeatedly got the same message
-when I pressed cancel, the desired (uploaded) watch face was accesible and customisable.
-just in case, if the file was corrupt, I changed the name of the watch face, uploaded it again, and…
…since then I cannot access the watch faces on the phone.

Hope this helps and thanks again for reporting the bug.

Gorazd.

New complaints are coming… Maybe a hotfix needs to be done on the Wearable App…:

https://www.reddit.com/r/GalaxyWatch/comments/yx7yae/new_faces_will_not_show_up_in_the_wearable_app/

I installed last update of the Wearable App, yet the problem still persists.

It causes by google’s problem.
Please try this.

Watch > Play Store > Manage apps > Wear OS by Google smartwatch > Uninstall (only updates will be removed)

1 Like

I know a user who uses the Wearable app in version 2.2.53.22101061 and Galaxy Watch4Manager 2.2.11.2210275 and the new WF are displayed there. An update is offered, but I don’t know if the error exists after the update.

We have reported it and are trying to track this down,

Ron
Samsung Developer Relations

@Matteo_Dini

I responded on the Reddit page. That was almost certainly a case of not scrolling down but expecting it to appear immediately.

Ron

@r.liechty_SDP

Hi Ron,

thank you for your contribution!

Unfortunately it seems that even scrolling down, the Watch Faces are not displayed. I’m also getting feedback via email for the same reason.

I still don’t understand if it is related to too many downloaded watch faces.
For my part I have not found an issue, but I have installed about 20 watch faces on my watch / phone.

We are getting other weird issues regarding the Wearable App syncing with the watch. Customizations and now this Watch Faces not showing in the download tray. I recently had a watch face pop up in the favorites that I’d never seen before.

Anyway we have reported it.

Ron
Samsung Developer Relations

3 Likes