Pushing edited aab file

Hi this topic may be outside this category. But mind me. I have found watch face format within the ab
Ab file. Edited the xml file and put it back into .aab wonder is there a way to push this new aab into my watch via adb…?

You may try to create an apk file and send it to watch via adb command. As far as I know aab is not supported for add command. You can check more details from here android - How to deploy an aab file on the device? - Stack Overflow
Here an alternative shared for extracting APK from aab.
**BTW WFS create both Aab and APK

Hi didnt work…some signature/version appear as the error

For which process you are facing issues? Have you tried to create apk using WFS and deploy it using adb command? Please clarify on which step you get the error.

Bundletool install-apks …

Also if i did nothing to the apk published by the wfs
And did

Adb install … also similar error…

Anyway i am put at the moment. Will try again to get exact errors… later or tmw

As the latest WFS by default give you apk file I don’t think so you need to use this approach. just build the project and deploy the apk using adb command.

Adb install … also similar error…

Signing issue…but wait for my reply on the error

I am unble to deploy from wfs? Because i am editing the resulting apk/adb

To add features wfs can support

You can directly deploy on Watch from WFS using “Run on Device” not Publish button. Publish button helps you to create apk/aab file and you can deploy the apk file using adb command. Should I share the adb command for install the apk on Watch?

As i said i used this cmd to

adb install -r /path/to/your-filename.apk

Didnt work.

I know run-on-device but for my case need to use adb instead

If you set the adb path on the environment variable you can install the apk from where the apk saved. If you don’t set the adb path please go to the adb.exe file path. Copy the apk file to that path. Open the cmd prompt and type this command “adb install filename.apk”.
You can check is your watch isn’t connect or not before giving the command. Type adb devices to test.
Check the image from below:

Hi its say cert no found its has been sign etc

That my rought error…show u later.

I know how to path my adb…because i use it for connecting to my watch so as to test out pair and connection for other forum users

failed to install com.watchfacestudio.untitled.apk: Failure [INSTALL_PARSE_FAILED_NO_CERTIFICATES: Failed to collect certificates from /data/app/vmdl1194561972.tmp/base.apk: META-INF/KEY0.SF indicates /data/app/vmdl1194561972.tmp/base.apk is signed using APK Signature Scheme v2, but no such signature was found. Signature stripped?

here is my error …

I think is the way i edit that cause this

Did your adb devices command worked? The error seems adb related error.

If unedited apk file. Meaning if i for testing i publish from wfs the apk. Then run adb commands i managed to push it to the watch.

This error occured if i replace the xml directly to the apk.

So i thinking its because the signature check failed.

It expected since i changed something in the package.

Anyway think this edting medthod not so straightforward.