Installing non-debug apk/aab on GW4

WFS lets you Run on Device and, when you do, the debug version is installed on the watch. How do I install the build version of my new watch face onto my Galaxy Watch4?

I don’t want to upload the watch face to Google Play.


As far as I know if you deploy your design using run on device your design will be in your watch until you reset your watch.
If you want to deploy your watch after build the design you can also do this simply using run on device.

@Boshra thanks for replying. I wanted to install the build version rather than the test/debug version to see if there’s any difference.

To install the (non-debug) .apk, file, I found you can use the adb command:

adb connect
adb install -r "/myfolder/myapp.apk"

The IP address is the IP address of the watch, which must be on the same network as the PC.


Sweet that goes in my list of helpful hints !!


You’re welcome :slight_smile:

Here are a couple of how to guides that might be useful in the future:

1 Like

This solved my problem.

My main laptop didn’t see the clock. None of the ways helped me.
I used a second laptop to install the dials. It was uncomfortable.


HI Roman,

if your main laptop didn’t see the watch (show connection when you entered adb connect it may have been on a different network or using VPN or a firewall.

If it did show the connection then it should have loaded from WFS (once WFS restarted).

Samsung Developer Relations

Hello Ron!

I tried all options.

The laptops have the same network and firewall settings.
Connected the clock using “adb”. Turned off and turned on “WFS”. Reset clock settings, rebooted. Disabled firewall. It did not help. My main laptop does not see the clock. The second laptop does not experience any problems.

But now I can send the .apk file to the watch. I no longer need a second laptop for this.

Hi Roman,

I had to Revoke Debugging Authorizations to reset them so it asked about being debugged again. Maybe using a second computer reset that.

Glad it is working, Strange new tools and I’m just getting used to them myself.