S24 Ultra - Developer Option - USB Debugging Greyed Out

With my Galaxy S24 Ultra, I am not able to enable USB debugging in the Developer Options. It is greyed out. I have never seen this with any previous Galaxy note nor g-series phones. It is an unlocked S928U1 purchased from Samsung. How can I enable it? Thanks…

1 Like

Strange, are you sure you have Bluetooth enabled?
There are some USB items greyed out but I was able to turn USB debugging on
See this How to from Verizon

Ron
Samsung Developer Relations

Thanks. This has nothing to do with Bluetooth. But yes, Bluetooth is enabled. The “How to from Verizon” does not have the "USB Debugging option greyed out as mine does. So it does not apply to this problem.

Sorry Stuart, I meant USB enabled for Data Transfer.

I don’t know if this is necessary for ADB debugging or not but for file transfers

  1. If necessary, touch and hold the. Status bar. …
  2. From the list of notifications, locate then tap the USB option (e.g., USB charging, USB for image transfer, etc.). If necessary, tap the notification to expand it.
  3. Select. Transferring files.

Ron
Samsung Developer Relations

Thanks. I need USB Debugging enabled. That is all. This has nothing to do with File Transfers. However, I did select “Transferring files” as you suggested. “USBS Debugging” is still greyed out. I think you know I need “Developer Options, USB Debugging” enabled and not greyed out. That is what needs to be resolved.

I checked the documentation and I checked on an actual S24 Ultra and USB Debugging should not be greyed out and was not on the device I tested.

The only thing I can think of is if you installed some virus protection app, but I assume you would have thought of that first.

Since this is a new device I would suggest you contact Samsung support about this or you do a factory reset (be sure to back everything up to google account first) and see if that restores the USB debugging.

If you find a reason for this please let me know, I’m very curious.

Ron
Samsung Developer Relations

Thanks for your assistance. Samsung support performed remote access via Smart Tutor without success. So they submitted an Error Report via Samsung Members app. The only reply so far is a canned msg, “thank you for submitting the error report …” Wishing for some good luck here. I only transferred apps from an S23 which has no issues like this. If I don’t get any further replies, what other support can I attempt with Samsung? Thanks.

I have to ask the obvious… you did turn on Developer Options by tapping on the Build Number 7 times and entering your PIN number.

Ron
Samsung Developer Relations

Thanks for the suggestion. Yes - That is the only way to see the USB Debugging option as far as I know.

I did a factory reset and then went through all settings starting from the top. I would check if USB Debugging was greyed out or not. When I enabled Security and privacy > Auto Blocker, it would turn USB Debugging off and grey it out. It clearly states “Block commands by USB cable” and then gives a brief explanation. But hey, Who reads the fine print! :slight_smile:

Hopefully, this can help others out in the future.

3 Likes

I was having this issue today and turned off autoblocker completely in security settings and it allowed me to enable usb debugging. Glad I didnt have to factory restart

Awesome @owillis. I did the reset out of frustration so I could start with it NOT greyed out instead of trying to get rid of the greyed out.

Glad my little discovery has helped someone out. Long live peer forums!

1 Like

Helped me too. Thanks!

1 Like

Helped me too. Thanks

Do a reset many time wont help

If you have not changed any options other than to attempt to enable adb debugging, I have no suggestions if you are not using a custom ROM.

1 Like

I had the same issue and this solved it. Thanks Stuart.

Thanks for letting me know.