Startup error code

Hi, I installed Galaxy Watch Designer application but it gives error message when I want to run it. Can you help me?

GalaxyWatchDesigner hata

resolved when java installed new version.

For others
Error 13 is when you have a 64 bit Java app and 32 bit Java installed or vice versa.

Galaxy Watch Designer uses the 64 bit Eclipse IDE.

Ron
Samsung Developer Program

Ron, I keep getting this notice: JRE 1.8 (64bit version) or above is required. Please download at http://java.com/en/download/

I’ve downloaded an installed the java software from this link but it keeps occurring. Do I need to download the 64 bit Eclipse IDE software from the Eclipse foundation web site?

You probably have the path set wrong.
open command prompt and type
java -version
if it shows the information you probably still have the 32 bit Java installed
If it doesn’t show any information you don’t have the
C:\Program Files\Java\jre1.8.0_231\bin; (it may be 241 version now.)
In the path,

Type in
path
and make sure you have the correct path. If you had an old one then it may still be in the path.

If you don’t know how to set your environmental variables I can help or there are several tutorials on line.

Ron

Ron, thanks for the quick reply! I opened a prompt window and it gave me a “java-version” is not recognized…
I typed in path, it gave me: PATH=C:\Program Files (x86)\Common Files\Oracle\Java\javapath;C:\ProgramData\Oracle\Java\javapath;C:\WINDOWS\system32;C:\WINDOWS;C:\WINDOWS\System32\Wbem;C:\WINDOWS\System32\WindowsPowerShell\v1.0;C:\WINDOWS\System32\OpenSSH;C:\Program Files\Microsoft SQL Server\Client SDK\ODBC\110\Tools\Binn;C:\Program Files (x86)\Microsoft SQL Server\120\Tools\Binn;C:\Program Files\Microsoft SQL Server\120\Tools\Binn;C:\Program Files\Microsoft SQL Server\120\DTS\Binn;C:\Program Files (x86)\Plantronics\Spokes3G;C:\Program Files (x86)\Common Files\Intuit\QBPOSSDKRuntime;C:\Users\joe\AppData\Local\Microsoft\WindowsApps;

I know I installed Version 8 Update 251 (build 1.8.0 _251-b08) installed.

These are for the x86 version of java
PATH=C:\Program Files (x86)\Common Files\Oracle\Java\javapath;
You need to remove that you don’t have the x86 version or it would have shown in the
java -version (you did have a space between java and -version right?

open file manager
right click on This PC or whatever you named it
select properties
Select Advanced System Setting
Select Environmental Variables
In the System Variables box click on Path then select edit
you’ll see those first two lines
C:\Program Files (x86)\Common Files\Oracle\Java\javapath;
C:\ProgramData\Oracle\Java\javapath;
Delete the first one for x86
Click OK close the environmental variables box

Open a new command prompt
type java -version
hopefully it will show your new version if not
go back to environmental variables again
Path - Edit
delete C:\ProgramData\Oracle\Java\javapath;
and
select Browse for folder(not file)
and select the folder
C:\Program Files\Java\jre1.8.0_251\bin
and add that to the path,
OK out of environmental variables
New command prompt (needs new after every change)
type java -version and it should all be set
GWD will launch without an error

Ron
Samsung Developer Program

Actully, i didn’t have the space. i retyped it:
java version “1.8.0_251”
Java™ SE Runtime Environment (build 1.8.0_251-b08)
Java HotSpot™ Client VM (build 25.251-b08, mixed mode, sharing)

That is the (x86) version of Java you may have both versions or installed the wrong version

Java HotSpot™ 64-Bit Server VM (build 25.231-b11, mixed mode)

Go to add remove programs and look for Java you may have both installed and the computer is loading the 32 bit version instead

If there are two version of Java installed delete the x86 version and reboot
If there is just 32 bit version installed deleted it and install the 64 bit version from the download site.

Ron
Samsung Developer Program

Ron, Thanks a million. I uninstalled and reinstalled the correct version. My confusion was with the terms used in the downloads area of Oracle - the correct file was called Windows Offline (64-bit). Offline confused me. 1.8.1 is installed and running now.

The Offline is the method of installing it (download then install).
I’m glad we got it sorted out without too much pain.

Enjoy GWD it can be adictive.

Ron
Samsung Developer Program

Thanks. Since I have your attention, I thought I’d ask another unrelated question. You wouldn’t happen to know why the digits for my digital clock (or any other complication like step count) won’t show on screen? In the earlier versions this wasn’t a problem. I am sure it’s got to be a setting…

Never mind. It had to do with the fonts. once i selected another font from the system it worked fine. Sorry to bother you again.

HI Joe,

There is a quirk in GWD 1.8.x that after your install it you need to reboot for all the fonts to show up. Something about them being cached. that probably was the problem try your old ones again.

Ron
Samsung Developer Program