The connection to the clock does not work

Hello everyone. The connection with the clock via WIFI stopped working. Everything worked before. And suddenly the application just stopped seeing the clock. I’ve tried almost everything. Reset hours, reset the router, did not reinstall only Windows (this is an extreme measure). Tell me, maybe someone has already encountered this? Firewall exception added. Everything related to the network everywhere an exception is added. The request for the watch just doesn’t reach. It was like this for 11 Windows. I installed 10 windows with full reset and everything worked fine.

Hi Wixej,

It seems like this is closely related to Windows 11. If all works fine for Win10 I would strongly suggest staying with Win10 until Win11 is settled down and the majority of the issues are resolved.
It is not much help from me, but most of the devs will tell you that your peace of mind is closely bound with the stability of the tools you are using :wink:

I have Windows 10 installed now. And still, there is nothing that does not work

Wait the minute, from above I understand that in Win10 all works. So what is the problem?

does not work in windows 10

I don’t think that windows 11 should be any different from windows 10, I have run WFS on both.

The only connection problem that I have had is that sometimes the watch switches over to another wifi network. Resetting the watch back to the same wifi as the PC and checking that I’m using the correct IP address has always resulted in an immediate connection.

If I have a problem with watch <-> PC connection, I do:

At the watch:

  • Turn off Debug over WiFi
  • Revoke debugging authorisations
  • Turn off WiFi

At the PC:

  • close WFS

Then:

At the PC:

  • Open WFS

At the watch:

  • Turn on WiFi
  • Turn on Debug over WiFi
  • Grant debugging authorisations when watch asking to do it.

I repeat this until I get the question for granting debugging permissions for my PC at the watch.
REMEMBER TO HAVE THE PC AND THE WATCH CONNECTED TO THAT SAME WIFI.
IT WILL NOT WORK IF THE WATCH IS CONNECTED TO WIFI WHILE THE PC IS ON ETHERNET CONNECTION, EVEN IF IT IS THAT SAME NETWORK.

Even if I manage to get it to work at one session, after a few days, I need to repeat the above steps.

It is not ideal. I would prefer to get a stable connection every time I turn on WFS, and my watch and PC are connected to that same WiFi, but it is never the case.

I hope it will help you to establish a stable connection at least for one session.

Regards
Adam