WFS wont connect to GW5? (Solved)

I’ve spent days trying to get my WFS to connect to my GW5 Pro. I’ve followed so many tutorials over and over. I’ve come to a conclusion:
A) There’s something I’m missing or doing wrong that is so obvious that its being overlooked.
B) Someone purposely made WFS work through a wireless environment only therefore making this PC software not actually useable on PCs (I do realise how dumb this sounds but I’ve run out of ideas).

I run WFS as admin. Load up the face I’ve been working on. Go into dev option on watch, make sure ADB debugging is on. Check Debug over Wi-Fi for ip address. In WFS I click run on device and wait for it to say no compatible devices. Click the + and check the ip matches my watch wireless ip (also both my PC and watch are 192.168.1.X). Hit ok, wait a cple mins. Click cancel. Repeat the last few steps a 2nd then a third time. Then go into wireless debugging and try again 3 times. Then try clicking on pair new device (I realise that no one says I need to do this, but might as well try). Try this 3 times. Reboot PC, restart watch, try again.
Can’t connect at all.

Bluetooth debugging isn’t an option as the option I need to turn on in the phone doesn’t exist any more.

Any help or suggestions would be great thanks.

1 Like

Sorry, I have no experience with WFS connection, but after experience with earlier tool from Samsung, the GWD/GWS which recognized my watch sometimes on 20th attempt, I can only give one lame advice: try a dozen more times than only 3.

1 Like

Welcome @DethBringa . I am no expert but Enjoy a successful connection between my Windows 11 laptop and my Watch . I have to say it is sticky and a Reboot of both is often required . Once the connection is established it is Faultless till the next time .I have a GW4 Classic .
I also check Wireless debug on my watch .Check both options down the bottom . Check the item that is already ticked . I find it counter Intuitive . I also check Revoke debugging authorisations . I check the cross there .I think it stops you having to confirm a transfer .

I am working from memory I have screen shots and Dope sheets on my Laptop I can send later if you are still stuck .

BTW I highlight the IP address by clicking on it then press Return .
Lots of strange little Habits because it works .
Oh yes, and a little Voodoo helps .

Paring the Device is for Bluetooth only . Perhaps you should try switching that off till you have a connection . Bluetooth is better these days . I used to create its own problems .

As I said I am no expert but the IP address of your Watch and your PC should not be the same as far as I know . I will check but I think I am right in saying your Watch is supposed to be connected to your WiFi Modem . Mine is .

Welcome to the forum!
WFS connection to the device can be tricky.

Like russel said, for me it’s also kind of a ritual every time to get it right, otherwise something misbehaves and the connection can’t be made.
Once that happens I usually need to fully close WFS and restart the whole process, otherwise on immediate second/third try WFS just can’t find my watch, even when following the steps that usually work.

As a first step, I always turn Bluetooth off on my watch before turning on the Wi-Fi.
If I don’t, my watch seems to prefer the Bluetooth connection and just turns off Wi-Fi randomly.

I usually turn on Mobile Hotspot from my phone, and connect both PC and my GW4 to it, making sure they’re both on the same network with super strong connection.

Next, with debugging constantly on (no need to turn it on or off every time), I open Wi-Fi settings on my watch, and keeping the watch screen on, I retype the IP address from the watch into WFS under “Add device” and tap ok.
That’s it - WFS then finds the watch device within seconds.
I realize how it might sound silly or unnecessary, but following these steps works every single time for me.

Important highlights:

  • turn Bluetooth off before starting the connection process
  • keep the watch screen on while retyping the IP address and connecting to WFS (rotate bezel or swipe up-down every so often, if necessary)
  • make sure the Wi-Fi connection is rock-solid

Hope some of this helps, and good luck!

1 Like

I think we all need a Visiting Witch Doctor :::)))

Peter, thanks any advice is good I’ll continue trying.

Russel, With regards to the ip address being the same they are different but within the same range the X i used is specific to each device. So my PC is and watch
Lots of helpful stuff there for me to try though thanks. Those screen shots and things might be helpful but I’ll have a few more attempts.

enkei, More helpful tips there thanks. I’ll make sure the turn off bluetooth when trying now. I do have a good connection as I’m in the same room as the router, connecting the watch to the 5ghz and I’m sitting 5metres from the modem/router

I tried the ipV6 address instead but the WFS connection only identifies the ipV4 ip address.
Another question I have is, do I just spam the scan devices button, click the + and highlight ip then press enter or actually close that little window and press run on device? Or should I open cmd and spam the adb connect [ip adress]

1 Like

Every forum has its own system for replies and things, still learning this one.

So after about 1/2hr of voodoo I got it to work. I ended up following all the info you guys gave me and then connected with the CMD command.
My watch face is a work in progress but I’ve got the battery so display as a colour changing glow around the outside edge, I have a flashing envelope icon on the right for notifications and complication at the top for my calendar.

That upload limit is tight. But with some editing and playing I got it to work. Here’s where I’m at so far.


OH . Yippee you got there . You are well more Knowlage able with this IT stuff than I am . welk done .Nice Face .:+1::slightly_smiling_face::joy:

Samsung hasn’t allowed Bluetooth debugging on Watches for over 3 years and I believe that Wear OS will not allow it in the last or next update. It is considered a security issue.

For anyone else with the issue Here is my FAQ Answer. And command line connection seems to be the final solution when all else fails.

Your watch and computer need to be connected to the same WiFi network. Unplug or turn off the Ethernet adaptor if you have your computer connected by Ethernet
You cannot have Firewalls or VPN enabled.

Go to Settings
scroll down to About Watch tap on it
Scroll down to Software Info tap on it
Scroll down to Software Version tap on it 7 times and a dialog will open saying developer options enabled

Go to Settings
Allow the permissions as the watch requests them.
scroll down to Developer Options tap on it
Select ADB debugging tap on it
in those options, enable ADB debugging, and select debug over WiFi
it may take time to connect it took me about a minute before it shows the connection.
The first line will have your IP address followed by :5555 the :5555 is the port for debugging

Go to Connections and write down the IP address your router assigns to your watch.

From Watch Face Studio build your project with the wrench tool
Run on Device with the watch icon next to the wrench
It will search for your watch if it doesn’t find it. (it usually doesn’t)
add your IP address when you run on device in the + dialog and do the search again.

You Watch will pop up an permission to allow debugging or something like that select don’t ask again on this device allow.

After the restart run on device should work it will spin quite a while then say launch completed.

If it doesn’t

Using File manager copy the address where you installed adb by default
(copy the address as text from file manger using right click on the address bar)
Open a command prompt
navigate to the folder address
cd C:\Users\USERNAME\AppData\Local\Programs\WatchFaceStudio\tools\window
Then type
adb connect 192.168.x.x:5555 (where 192.168.x.x is your watch’s IP address).
It may take a minute to connect or give a failure response
If you get a rejected error or something check your watch debugger settings.
Try in developer options to revoked permissions and force new acceptance. do the connect again.

select “run on device” within Watch Face Studio, your watch should show up.

If it connects but will not run on device create a new keystore in a new keystore folder

p.s. I like your watch face it is unique and really a watch FACE

Samsung Developer Relations


Thank you. The graphic was originally given to me as fan art when I was a twitch streamer. I have made it into a parallax background on my phone so now both match. A little more tweaking is needed as when I get a notification I still get the red dot pop up on top of the envelope animation I added so I might incorporate the red dot into a red pulse. Looks good so far though.

1 Like


For Galaxy Watch 4 and newer go to settings → notifications → Advance Settings and you can turn off the dot for notifications.

Samsung Developer Relations

1 Like

Awesome! Thanks for that, its a very handy thing to know.

1 Like

I used to be able to connect fine. But I dont know if its the new update or not but it now asks for Pairing Code. I enter it. My watch shows my desktop as a connection but still wont connect to WFS


I can only say try again…sometimes the watch drop off the wifi network…due to the time out or something

I sometimes need to try at least 5 times before the pc connects to the watch

Found this on google
Might help

1 Like

I believe you have to pair new every day.

I’ve been trying the last four days. Still not connecting

Try this

I am using adb that comes with lastest android studio.

Wfs = 1.5.7

Gw 5 (wear os 4)

Probably put your watch on charger…
Or turn off bluetooth. It works fine for me

I believe there’s is no need to use CMD if you are using WFS 1.5.7. You just need to input the information there and it’s easier. The above set of instruction is only for those who still using the WFS 1.3.13 to connect with GW6 and updated GW4 and GW5.

True, but i dont know why he having problems so give him another method…with better instruction to try

Incase it wfs just not showing…so troubleshooting via elimation

@brian.belinge like @Ballozi says u could try wfs method again. This time turn off bluetooth or put watch in charger.

Note; something to try when pairing dont press the back button. Leave it untill successfully paired.

Meaning leave it on the pair screen

I’ve tried all that. Watch automaticly goes back when it pairs. But WFS still doesnt find it. also sometimes the paired connection shows blank on the watch. Also, Im using the numbers at the end of IP as IP Port and Pairing Port. Is that correct?