WFS does not detect my device anymore

Hey, so I was able to get my watch connected to WFS last week. After rebooting my PC over the weekend it will not connect anymore. I have both the watch and laptop connected to my wireless network, and my watch has ADB Debugging and Debug over WIFI enabled. When I scan for device or enter the same IP as I did last week, it doesn’t detect the watch nor gives me the “pop up” on my watch to accept.

Im running the Samsung Galaxy Watch 4 and vrsion 1.1.14 of WFS. Someone posted about a 1.1.19 version, but I can’t find that listed here:
Watch Face Studio downloads | Samsung Developers

What else can I try? Thanks.

I get this sometimes. Usually rebooting the watch and then re-issuing the adb connect command from the PC resolves the issue - i.e. you get the pop-up on the watch and WFS will see it. There may be a better way to get around this, but this method works for me.

Oh, plus, you should issue the “adb disconnect” command on the PC before re-issuing the adb connect command otherwise the PC may think you’re already connected to the watch.

1 Like

When I scan for device or enter the same IP as I did last week, it doesn’t detect the watch nor gives me the “pop up” on my watch to accept.

in the Developer Options the option just below is Revoke Debugging Authorizations if you accidently hit no to enable debugging that will reset it.

Im running the Samsung Galaxy Watch 4 and vrsion 1.1.14 of WFS. Someone posted about a 1.1.19 version,

I think that was a typo I made.
The first time after rebooting when Run on Device you need to go to add the watch IP address but just click on it and then OK if it is already there and the Watch should pop up allow debugging message.

If it doesn’t go to the Watch Settings Developer Options and look at the ADB Debugging and see if the the IP address is the same one you used. Some (especially older) modems change IP address for what seems like no reason.

If it still doesn’t work
Using File manager copy the address where you installed adb by default it is
C:\Users\USERNAME\AppData\Local\Programs\WatchFaceStudio\tools\window
(copy the address as text from file manger using right click on the address bar)
Open a command prompt
navigate to the folder address
cd C:\Users\USERNAME\AppData\Local\Programs\WatchFaceStudio\tools\window
Then type
adb connect 192.168.x.x:5555 (where 192.168.x.x is your watch’s IP address) include the :5555 it is the portal
That should force the debugging authorization and it stays up a long longer. It will say failed to connect until you click on the allow debugging running the command again shows it connected.

If that doesn’t work Reboot your watch by holding down both buttons for about 15 seconds until it says rebooting and restart (not just turn off and on) your computer to clear any caches. But I’ve never seen the command prompt not work.

Ron

Hey Ron, What do you mean by where I installed ADB on my PC? I only installed WFS. Looking in this location there is no “tools” folder.
C:\Users\USERNAME\AppData\Local\Programs\WatchFaceStudio\tools\window

I installed it under this:
C:\Program Files\WatchFaceStudio

Im assuming that’s where I need to go in order to run adb connect. How do I type it in order to get into the “program Files” directory?

I tried this but got an error:
C:\Program Files\WatchFaceStudio\tools\window
‘C:\Program’ is not recognized as an internal or external command,
operable program or batch file.

Thanks for your help.

It shouldn’t matter where the adb is located

C:\Program Files\WatchFaceStudio\tools\window

change directory with the cd command
cd C:\Program Files\WatchFaceStudio\tools\window

C:\Program Files folder is for global apps, the Users…App Data\Programs is for single users apps now

Ron

So I tried this and got an error:
C:\Program Files\WatchFaceStudio\tools\window>adb connect 192.168.20.20:5555
cannot connect to 192.168.20.20:5555: A connection attempt failed because the connected party did not properly respond after a period of time, or established connection failed because connected host has failed to respond. (10060)

I also tried rebooting the watch too and that didn’t work.

it always says that the first time. Once you OK pop up for debugging on the watch then run the same command again it says connected

It it still says failed to connect check your watch settings developer options and make sure that adb debugging - WiFi Debugging is on and it should list your IP address in the information after it connects

Ron

So my laptop is connected to the same wifi network as my watch. ADB debugging in on. Debug over Wifi is on with the IP address being shown. When I try the adb connect using the command prompt, nothing happens on my watch. A few moments later I get that CMD error.

I also tried uninstalling WFS and reinstalling it. That did not work either.

I reset my watch and it’s working now. I guess that’s another solution…

That was the fix for the old Tizen based watches. Probably at some time you selected to not allow debugging by accident, resetting would fix that.

Glad you are up and running. Enjoy designing watch faces !!

Ron
Samsung Developer Relations

Came into the office again, did not reboot anything, launched WFS, can’t connect. Tried the adb command prompt, it did not trigger the watch. Checked to make sure my laptop is on wifi, ADB debugging is on, Debug over wifi is on with IP address showing. Run on device did not detect the watch. Add deviced with the IP address did not work either.

Tried turning off Debug over wifi and then turning it on again, did not work. Tried turning off ADB Debugging and then turning it on again, did not work. Tried shutting off the Developer Options and then turning it on again, did not work. I don’t know what else to try.

Also tried rebooting the watch as well and made sure everything was on, still didn’t work.

Hi Adam,

Do you have a VPN or some other firewall in your office or router? I know I can’t use my work computer to connect to my watch, I have to do everything from my home computer.

Be sure the computer is connected to WiFi and is not connected by ethernet cable. I know that connecting by both will work on occasion but rarely.

Try turning your bluetooth off see if that makes any difference (it shouldn’t)

Do not have Power Saving Mode on that may not allow debugging for some reason.

From the command line launch of adb do you still get the
A connection attempt failed because the connected party did not properly respond after a period of time, or established connection failed because connected host has failed to respond. (10060)

In ADB there is revoke debugging authorizations try turning it off to force the acknowledgment

I’m pretty much out of ideas after those.

Ron

Hey Ron,

Im sure there’s a firewall setup, but I dont have access to it. It’s odd that it initially worked for a few days, then stopped. When I reset my watch it worked again for a day, then stopped. I made sure my ethernet cable is unplugged when trying to get it to work. Power Saving on the watch is off. I still get that ADB error too. And I did shut off the ADB Debugging and got the checkmark (Are you sure?), but that didnt seem to help.

I also tried resetting the watch again like yesterday, but that didn’t work either now. I did get a vibration when trying to connect, but I did not get a popup notification.

Hi Adam, I get the problems you are experiencing all the time. Had it yesterday in fact. After rebooting the watch, adb connect didn’t cause the pop-up to appear on the watch and WFS would not detect the watch, so I issued ‘adb disconnect’, then adb connect and that that sorted it.

Seems extremely flaky in its behaviour.

Rob

Its frustrating Rob, that’s for sure.

We used to see this a lot with older dual band modems. The computer would be connected to one band and the watch to the other. I don’t think that happens with newer modems.

I think using command prompt launch of adb may work better than WFS. I know the first time I run on device it says no devices found until I select my already added IP address.

I don’t see any Support requests with this issue if you track anything down let me know.

Ron
Samsung Developer Relations