Unable to install tizen studio 5.6 on sonoma

I have the latest Sonoma, M1 chip, Latest Java SDK, and JRE. But I’ve been having no luck installing the TizenStudio. The installer would run and then close. I tried through CLI and had no luck as well. I got this error when running the installer on the terminal:

installer.jar exists

Exception in thread "main" java.lang.UnsatisfiedLinkError: no net in java.library.path

at java.lang.ClassLoader.loadLibrary(ClassLoader.java:1871)

at java.lang.Runtime.loadLibrary0(Runtime.java:871)

at java.lang.System.loadLibrary(System.java:1124)

at java.net.InetAddress$1.run(InetAddress.java:295)

at java.net.InetAddress$1.run(InetAddress.java:293)

at java.security.AccessController.doPrivileged(Native Method)

at java.net.InetAddress.<clinit>(InetAddress.java:292)

at org.apache.logging.log4j.core.util.NetUtils.getLocalHostname(NetUtils.java:59)

at org.apache.logging.log4j.core.LoggerContext.lambda$setConfiguration$0(LoggerContext.java:620)

at java.util.concurrent.ConcurrentHashMap.computeIfAbsent(ConcurrentHashMap.java:1660)

at org.apache.logging.log4j.core.LoggerContext.setConfiguration(LoggerContext.java:620)

at org.apache.logging.log4j.core.LoggerContext.reconfigure(LoggerContext.java:699)

at org.apache.logging.log4j.core.LoggerContext.reconfigure(LoggerContext.java:716)

at org.apache.logging.log4j.core.LoggerContext.start(LoggerContext.java:270)

at org.apache.logging.log4j.core.impl.Log4jContextFactory.getContext(Log4jContextFactory.java:245)

at org.apache.logging.log4j.core.impl.Log4jContextFactory.getContext(Log4jContextFactory.java:47)

at org.apache.logging.log4j.LogManager.getContext(LogManager.java:176)

at org.apache.logging.log4j.LogManager.getLogger(LogManager.java:666)

at org.tizen.installer.util.Log.open(Log.java:75)

at org.tizen.installer.util.Log.getLogger(Log.java:144)

at org.tizen.installer.ui.wizard.WizardUIMain.<clinit>(WizardUIMain.java:68)

Anyone experienced a similar issue and was able to fix it?

I do not think Tizen Studio supports the M1 chip

It worked with the previous version. Are you saying they don’t support it anymore?

Hello. Can you please specify which specific version worked previously with the M1 chip?

It was version 4.6. Then it stopped working after I updated my mac OS to sonoma (This was a big issue). If I understand correctly, version 5.6 should be compatible with Sonoma. I’m just not sure If M1 chip is compatible.

Hello jhoon1109,
Currently, Tizen Studio does not support M1 Chip. And it’s applicable for both Big Sur and Sonoma.
This is the reason you are unable to install it on your PC.


Do you have any alternative suggestion so I can run/deploy the app to the TV using my mac?