WatchFaceStudio e Watch 4

Good morning, I apologize for my English, I use the translator and I also apologize for my inexperience.
I was happily using Watchfacestudio to create watch faces for my Galaxy Watch 4.
After enabling ADB Debugging and Wireless Debugging in the Watch 4 developer options, in Watchface studio I pressed the RUN ON DEVICE button and was asked to enter the Input device IP address to connect and it displayed my Watch and installed the clock face.
Now, unfortunately, I get this message: Failed to pair a device (ip: Please need the data on the device or check your input,
In practice it doesn’t work anymore, I have tried a thousand solutions searched on the internet but with no positive results.
I kindly ask for help to resolve the issue. I also wondered if it could be a bug after the Watch 4 software update, I also did the recovery to factory settings but it doesn’t work.
Thanks in advance for your help.

If you are using WFS 1.5 7 then 99% of the time is you didn’t wait long enough before you tried again. It is totally frustrating and most people get the cannot pair and try again at least I have too many times.

Basically WFS gives the error message before the pairing finished but it doesn’t stop pairing. It may take up to a minute for the pairing to complete and you may have to OK something on the watch. Once it does pair then the watch icon shows in WFS and you can now run on device.

You can also pair with adb using a command line but it still takes as long to pair.

If you are using an older version of WFS then there are ways to do this but lots of hoops to jump through.

Samsung Developer Relations

Hope this helps too.

Thanks for the information, it will certainly help.

Thanks for your help

Good morning, I applied your advice to the rule.
I made sure that the WatchFaceStudio version is 1.5.7 and I activated ADB Debugging and Wireless Debugging in the developer options as per the attached photo (Photo 1 - Photo 2 - Photo 3).
I then pressed the “Run to device” button in WatchFaceStudio and entered the IP address and pressed OK but I received the usual error message as per the attached photo (Photo 4 - Photo 5).
I waited as per your advice for more than five minutes but nothing happens, it doesn’t work.
I also uninstalled version 1.5.7 of WaceFaceStudio as I read that it works with version 11 of Android, I have a Samsung S9 with Android 10 installed.
I then installed version 1.4.20 of WatchFaceStudio as a test but it doesn’t work with this version either.
The strange thing is that until the latest software update of my Galaxy Watch 4 everything worked perfectly, the version of the latest update of the Watch 4 is: One UI Watch 5.0 - R860XXU1HWH3/R8600XM1HWH3/ - Security patch level 1 July 2023.
The software of my Sansung S9 after the last update is: One UI 2.5 - Android 10 version
The latest S9 update: Version G969FXXUHFVG4/G960F0XMHFVB4/G960FXXUHFVB4 Security patch level March 1, 2022.
As already mentioned, I also tried to recover the Watc 4 without positive results.
I really don’t know how to fix the situation unless it’s a bug.
Thank you in advance for your help on this.

Sorry, I forgot the attached photos

@png.sanpaolo Did you read carefully the guide?

Did you click “circled” option on your watch?

And those three fields did you fill it up or left blank?
It wont pair if blank

I directly link to correct post for u

Fixed, thanks, it works now