Impossible to connect GW6 to watch face studio 1.5.7


I just go the new GW6 and wanted to make some new watchfaces with WFS. Everything works fine until the moment where I have to run the watchface on my device .

I did the wireless debugging and the watch was connected to my pc (at least that’s what it said on the watch) but still on WFS the same message appears “Failed to pair a device” “Please need the data of the device or check your input”. I tried to connect my PC to my home WiFi then to my mobile hotspot, disconnected my watch from Bluetooth, tried everything I found on the web and sill nothing.

I really need your help guys!



Hey @caramelleeed . May I welcome You . Have you ever sent Faces to any watch from WFS before . The watch is connected to you Router not the PC . Your PC is connected to the samre WiFi . Do you have the Developer settings on your Watch ? Have you Switched on ADB Debugging ?
I am a Beginner on WFS I have a GW4 and use WFS 1.3.13 . I know that you will be connected soon . I have some notes on my Laptop I can send later . I find I have to check the Wireless connections on my Watch before every session of Uploading . However one the Connection is established it works like a Dream an usualy takes 15 seconds to get on my watch .

I’ve had some trouble getting my watch to show up in WFS too.

What have worked for me is to enable developer options as you need on the watch. Then enter wireless debugging in dev options. Click the add button in run on device in WFS. Then enter your ip of your watch and first port number in WFS. Then click add new device on your watch, and enter the code and second port in WFS. Then click connect in WFS, it should be successful.

However after this the watch still haven’t shown up for me. What seems to work then is to restart WFS, and then the watch shows up. I’ve even had the watch shows up as two options in WFS, duplicates, but doesn’t seem to cause any trouble.

From what I understand you need to do these steps for each session when you want to run on your device.

Have a look here

That worked for me.

Hey, the developers options are obviously on as well as ADB debugging. The issue that i have is that on the watch after I go through the pairing procedure (with the code and port number) it says that my computer is paired but on WFS an error message is sent that tells that there is an issue with the pairing (see my previous post).

So the watch says that th computer s paired, but the computer says that it didn’t managed to pair the watch.

I’m so lost

The only only further tip I can give is that I did not use WFS to do ANY of the pairing, just the watch itself and the adb commands on the PC command line. Once I’d paired and connected via adb, the watch appeared as a target when I selected “Run on device” in WFS.


When you go to run on the device you have to watch it and wait up to a minute

On Watch click on settings then developer option
Turn on ADB debugging and ok that
scroll down to where it says WirelessDebugging tap on it
wait few minutes and
write down the IP address followed by :xxxxx the port number

Then click on Pair with new Device (apparently you have to do this ever day )
it will have a pairing code
followed by the IP port and a different port number

Run on Device
fill in the IP address in the top
Fill in the first port number when you first turned on ADB Wireless deguggin
Fill in the Pairing code
Fill in the last port number when you paired the device

You can try running on watch now but you may have to ‘add the app’ so look for a notification on your watch I had to do this each day too.

Let me know if that doesn’t work. It may be a caching thing

Samsung Developer Relations


I have the same problem when i try to connect my watch6 with wfs. I try both solutions.
Connect by wfs, my PC is linked with the watch (i cab see it on my watch) but on wfs i don’t find my watch, try scan devices, nothing happen, only the error.

When i try with adb, everything work, paired and connect but same issue on my com, can’t find the watch.
I can control my watch by adb with no problem but not with wfs.

I try to reboot, restart wfs many times…

Something wrong between wfs and watch 6?

Help please!
Ps i try wfs 14 and 15

Or maybe if you have a command line for send the .wfs to my watch…

Hi, for adb you need to do 2 steps. Pair and connect.
But for wfs 1.5.7 u should just be using the u.i

In wfs if using “run on device” click the “+” sign instead if you not using adb.

Please read this topic.

Please don’t answer like this, i know how to connect and like i say it doesn’t work with wfs, i say wfs can’t see my watch, i understand how to use the UI and witch adress and port have to use its why i say i can connect and pair with adb.

I try with geminiman wearos too with my phone and i can install or delete apk and other stuff. The problem is with wfs.

Connection by ethernet got a problem apparently, people can connect by this way?

I answer like this is because my guide is base on others replies complied in one place. And in most case the connectivity is because ppl miss out steps

Like just put it as a mistake i miss read some points. Sorry

Anyways can u connect your pc to wireless also instead of using ethernet? It could be like u said pc is in ethernet and watch on wireless.

Is your band same band? 2.5ghz or 5ghz?

P.s if all still fails. U can try publish apk offline to generate a apk

Then run

adb install /path/to/your-filename.apk

No problem, it’s OK.
I try with a laptop and WiFi and it’s work perfectly.

I don’t understand why it’s doesn’t work with ethernet, all adb shell work perfectly but not wfs.

So people of you have the same issue, try with WiFi

1 Like

Hi, you not the only one, with the ethernet/wifi issue.
If i recall correctly.

But for me my pc also have wifi, so cant test this senario for people

Watches are more particular than other devices.

Ethernet is not WiFi and while sometimes it is on the same network as the WiFi , that is not always the case, and certainly not the case if you have an older router.

Also there used to be a problem with 2.5 mhz and 5 mhz bands but the newer routers run them both on the same network but not always the Ethernet.

Samsung Developer Relations

Its does not explain why it works on adb shell. If it works on adb shell mean theres a connection. But wfs cant see it. When ethenet is used

Anyways i managed to connect my laptop to ethenet of my router, no issues found. Could it be firewall?

@Knightwing @axel.valadon

You can be connected to your watch and have it not show up in WFS. With Wear OS it has to be paired and it has to have the port expected by WFS and it has to have debugging enabled and I believe file transfer OK’d (the first time)

My thought is that when you connect via ethernet through your router it uses a port not expected by WFS.

Samsung Developer Relations

Hi, when connecting with adb. Just like in wfs we use ports provider by the watch.

I understand and your point is what???


My point is so what is the port u say ethenet using a port not expected via wfs. Since the port are the correctly entered.

The Ethernet Port number not the adb port number