ADB connection problem

It has been about 6 months since I last used WFS. I updated WFS and SDK Platform Tools, but WFS can’t see Watch4. I think the problem is Watch4 keeps on disconnecting from WIFI for energy saving. Unlike Watch3, there’s no option to have WIFI always on.

What is the procedure for WIFI ADB?

That error message is because you did not accept allow debugging. (Same as the RSA Encryption Key for Tizen OS). You turn it on in developer options several seconds it connect to your wifi. you go to run on device and it asks to allow debugging. For me I get no devices available until after I click on the OK.

If you have your Ethernet plugged in it will cut out as you described if it connects at all.

Below is everything you need to know. :slight_smile:

Select Run on Device and add your IP address one time to the search using + icon
Select Run on Device
It will show no Devices found
again click on the + and click on the IP address to the run on Device at that time your watch will ask if you want to allow debugging. click yes If you don’t OK that in a 15 or so seconds it goes away and then doesn’t ask again unless you close and restart debugging
Your watch will show in the run on devices click on it.

Your watch and computer need to be connected to the same WiFi network. Unplug or turn off the Ethernet adaptor if you have your computer connected by Ethernet
You cannot have Firewalls or VPN enabled.

Enable developer options on your watch, and within those options, enable ADB debugging, and select debug over WiFi(it may take time to connect it took me about a minute before it shows the connection).
Allow the permissions as the watch requests them.
Go to Connections and write down the IP address your router assigns to your watch.
add that when you run on device in the + dialog.

If it doesn’t

Using File manager copy the address where you installed adb by default
(copy the address as text from file manger using right click on the address bar)
Open a command prompt
navigate to the folder address
cd C:\Users\USERNAME\AppData\Local\Programs\WatchFaceStudio\tools\window
Then type
adb connect 192.168.x.x:5555 (where 192.168.x.x is your watch’s IP address).
It may take a minute to connect or give a failure response
If you get a rejected error or something check your watch debugger settings.
Try in developer options to revoked permissions and force new acceptance. do the connect again.

select “run on device” within Watch Face Studio, your watch should show up.

If it connects but will not run on device create a new keystore in a new keystore folder


Thanks for the info. That’s what I’ve setup before, but it’s not working now for whatever reason. The watch doesn’t show any notification to accept allow debugging any more.

The watch has two WIF MAC addresses, how can that be? Watch4 registered on my WIFI router has a different MAC address than the one shown in watch’s Settings/About watch/Device/WiFi MAC address.

My workstation tower has no Wifi capability. Unplugging Ethernet is new? I have connected Watch4 with the same workstation tower before.

It’s working now. Using the MAC address on my WIFI router instead of the MAC address listed in watch’s setting. Plus I didn’t need to unplug Ethernet on my workstation tower. Thanks Ron.

I know there are some Apple WiFi Routers that change IP randomly, probably others. I’ve had luck connecting the computer to the ethernet but very often.

Samsung Developer Relations

With my galaxy watch 4, after latest update (android13, One UI 5.0) it’s no more possible to connect to adb via Wifi ???
Computer and watch are on same network, I can ping watch, ADB debuging enabled on watch, authorization to my computer given
But when I launch adb connect ip:port (using ip:port provided on watch), then connection failed
And adb devices always answer that ip:port connected but device is offline ???
Any ideas ?

To complete my issue, I also tried to reboot my watch, reboot my smartphone, reboot my computer, nothings worked.
I hope you will not explain me that it is no more possible to debug with adb and computer??? If it is that it is a shame…

On explain I should have this popup on watch, I got it with UI4.5, but not with UI5.0 (I tried to forget all devices, reboot everything; it never works)…
ADB Debugging in Galaxy Watch 4

On Watch, when I authorize a new device it never appears in “Paired devices list” and when I click on Pair new device, I get on Watch IP a new port and 6 numbers for pairing…
And so what ??? adb connect stil refuses this new IP:port and adb never request or propose number for mairing…
I could develop until now, and since update to latest UI it’s no more possible ???
Please HELP it’s URGENT!!!

C:\Users\Titi>adb connect
cannot connect to Aucune connexion n’a pu être établie car l’ordinateur cible l’a expressément refusée. (10061)

C:\Users\Titi>adb connect
failed to connect to

C:\Users\Titi>adb devices
List of devices attached      offline

C:\Users\Titi>adb connect
failed to connect to

C:\Users\Titi>adb connect
already connected to

C:\Users\Titi>adb devices
List of devices attached      offline


Click pair new device…then do a adb pair ip:port
Enter the pass code. First.
Or if u using 1.5.7 just click the +sign after run on device. Enter the ports accordingly.

Are you using WFS 1.5.7 or WFS 1.3.13?
With 1.3.13 ** Small question about WFS 1.3.13 and Galaxy Watch 6 - #9 by isaacok0919**

WFS 1.5.7 is pretty straight forward you do that in the Run On Windows settings
On Watch click on settings then developer option
Turn on ADB debugging and ok that
scroll down to where it says WirelessDebugging tap on it
wait few minutes and
write down the IP address followed by :xxxxx the port number

Then click on Pair with new Device (apparently you have to do this ever day )
it will have a pairing code
followed by the IP port and a different port number

Run on Device
fill in the IP address in the top
Fill in the first port number when you first turned on ADB Wireless deguggin
Fill in the Pairing code
Fill in the last port number when you paired the device

it also asks if you wish to add this device the first time and you have to OK it.

Samsung Developer Relations

Sorry for using this thread. I tried to open a new, but did not work.
I have a similar problem:
My PC with WFS 1.5.7 on it has a LAN cable connected to a router with the WLAN in which the watch 4 resides.
I turned off BT, turned on WiFi, went to the dev options, activated ADB Debugging and WiFi Debugging and pressed the button to couple a new device.
I get an IP and a port and the code.
After about 1 gazillion trys I tried to adb pair
adb pair IP:Port (the port that was suggested for pairing)
and hit enter.
I was asked the code and entered it.
The ADB on the console said, that the watch was successfully paired with adb.
BUT: WFS does not find the device.
Before the last firmware update on the watch, adb worked 100 % to connect the watch.


1)Click forum home, then create a new topic from there and
choose watch face studio as the category

To create a new topic.

  1. You do not need to run adb commands with wfs 1.5.7, follow @r.liechty_SDR instructions.

I already did follow these instructions, did not help.

That may be the issue they don’t always work with the computer on an Ethernet connection.

It also may just be you are giving up too soon.
It takes a while for the pairing to happen (up to a minute) and when it does it pops up on the watch.

So try it again but don’t give up just because it says no device found once it pairs it will show. If it doesn’t work after a minute

Samsung Developer Relations

Shouldn’t be resolving such connection issues top priority for Samsung?
I mean, beeing connected to the device you are developing for is almost an elementary base for developing. We all know the emulators are are pain in… some place …

First I developed for the Galaxy Watch (Tizen) and had some issues to connect to the watch.
Then I changed to the Galaxy Watch 3 and it got worse. In 75 % of the cases I had to use ADB.
And now on the Watch 4 with the new update even that does not really work anymore?
Right now I’m developing on my PC, push the files to my laptop to get a connection to the watch!

Hint: ADB connects very reliable.

Hi, if you still want to try via adb. Here are the steps actually

  1. adb pair (The last 5 digits are the pairing port number.)

2.adb connect (The port number is 5 digits, and it is a wireless debugging number.)

Did you do step 2? After the adb pair command as u did. U got to to do adb connect.

Didnt see it in your orignal post.

1 Like

The second step did the trick!