My watch face wont run on my device

I made a watch face for my galaxy watch 4 with watch face studio, but when I went to test it on my device, it just wont connect. I’ve tried connecting through its ip address and through my phone. all the necessary debug options are turned on, except bluetooth debug on the galaxy wearable app, but couldn’t find any settings for the app. when I press ok either going through my phone or entering the ip address, it does nothing. ive tried looking for answers and tutorials but couldn’t find much, can anyone help me with this?

I don’t care what the instructions say, I’ve never been able to connect using Bluetooth. I’ve had to use WiFi for the Watch4 WFS connection.

You do not need to turn WiFi on for ADB over WiFi to work it will enable WiFi automatically.

Here is the full solution with work around when all else fails.

Basics
Your watch and computer need to be connected to the same WiFi network. Unplug or turn off the Ethernet adaptor if you have your computer connected by Ethernet
You cannot have Firewalls or VPN enabled.

Enable developer options on your watch, and within those options, enable ADB debugging, and select debug over WiFi(it may take time to connect it took me about a minute before it shows the connection).
Allow the permissions as the watch requests them.
Go to Connections and write down the IP address your router assigns to your watch.
add that when you run on device in the + dialog.

Your device will not show up in the Run on Device window until you agree to allow access on the Watch pop up.

If it doesn’t

Using File manager copy the address where you installed adb by default
C:\Users\USERNAME\AppData\Local\Programs\WatchFaceStudio\tools\window
(copy the address as text from file manger using right click on the address bar)
Open a command prompt
navigate to the folder address
cd C:\Users\USERNAME\AppData\Local\Programs\WatchFaceStudio\tools\window
Then type
adb connect 192.168.x.x:5555 (where 192.168.x.x is your watch’s IP address).
It may take a minute to connect or give a failure response
If you get a rejected error or something check your watch debugger settings.
Try in developer options to revoked permissions and force new acceptance. do the connect again.

select “run on device” within Watch Face Studio, your watch should show up.

If it connects but will not run on device create a new keystore in a new keystore folder

Hope that helps,

Ron

got it to run, thanks for the help!

I don’t have the directory C:\Users\USERNAME\AppData\Local\Programs\WatchFaceStudio\tools\window I manually navigated to the subfolder Programs but there is no WatchFaceStudio in that subfolder. Do I need to install something else besides Watch Face Studio?

Also I am using Watch Face Studio on a desktop computer, i.e. it has Ethernet connection. Is this not going to work? I don’t have issues “communicating” between our wireless devices and my desktop (unless the devices are on the wireless guest network).

Edit: Never mind. I found this article and after downloading the platform tools at https://developer.android.com/studio/releases/platform-tools and starting adb the watch showed up when clicking on Run on Device. This is even with my desktop connected via LAN (rather than WiFi)

Regarding the Ethernet vs WiFi connection I think that depends on the router being used. When you install WFS it asks if you want to install for one person or all users. I’m not sure where it is put if you select all users. My guess is the C:\users\public\ folder

Thanks for the URL I’ll make a note of the tools site for others.

Ron
Samsung Developer Relations