Battery Icon not appearing

Hello Community,

I have a Ticwatch and have just updated to WearOS 3.5 and therfore have update WFS to the latest.

However I cannot get the battery icon to appear on the watch. It appears on my PC. I have tried all the complications that can display battery %. I get text and progress bars etc. But no battery icon.

Is this right? Is this a feature or known issue?

What complication you use?

  • long text, short text, range …

I have tried Circle, line, smallbox and largebox. Selected the Icon & Text, as well as Icon, Text & Title for each. The battery icon appears on the preview in the software. However when uploaded to the watch it does not appear. It works correctly for the sunrise ands weather. Does not display the calendar icon for next event either.

Hi @ollsbols , what version of wfs are u using? Either u using old wfs, firmware bug. Tried restarting your watch?

Or default layout choosen by the watch has no icon.
Just clicking on the layout doesnt mean u using that layout. Btw read my guide on complication layout choosing see if it helps.

Hi, I am using v1.5.7

I have tried restarting the watch. It made no difference.

I have tried several watchfaces that I have built on an old version and worked fine. Then updated to the new version when my watch moved to WearOS 3.5 and pthe problem started. Have removed and replaced the battery complication. I have create a new watch face with nothing but battery complications in various different states. No battery icon.

Hi @ollsbols , like I said make sure u follow the guide.people always comments or reply without reading and trying out what I say. U say u selects different layout. I suspect all the layout on the watch appears the same?

E.g circle only one layout. Because the battery complication will choose default.

you not have 3 different states if you are doing something like this.
but three circle complication with previews if the default complication chosen was that layout… so if you sent this to your watch all three will be the same.

When watch get updated the default layout maybe different.
so before wear os 3.5 its works because you lucky the default was selected with the icon, but now who knows unless we test in the way I explained in my guide.

I repeat just clicking the layout and putting on the watch face is not selecting a state…

As complication layout on the left of wfs when selected does not mean u are choosing that specific layout its just a preview of what would look like if a complication is using that layout. Most complication can have more than one layout it can use. If u have more than one on the left list the complication will choose a default from the list.

Similiar issue

Solved

I reply this way because all three people who ask about complication layout related stuff. Give me similar replies but only when they try as explain they realised they miss something, also following my example helps in the troubleshooting.

Hope this helps, if not it could be watch specific issue/bug
As its

works on my gw5 pro wear os 4, dont remember having this issue either on os 3.5. Before it updated to wear os 4. Could be another update beside just wear os version

1 Like

@matze_styles4you , @ollsbols

Edit: actually u can have different specific states on the same watch face. But its how you doing it.

Hey Knightwing, thank you for the advice. Sorry for the delay in responding, I just haven’t had time to try it out.

Anyway, I understood your guide so I am making sure I follow this.

On the topic of the batter icon it has not worked. But no matter. I have created a new animated icon that will show me charge level.

It must be something about the TicWatch. Thanks for your help.

Mobvoi devs on Wear OS 3 came with a brilliant idea of providing black #000 system battery icon. That’s why you’re not able to see it. It is actually there but black on black is black. Try adding some light background and place complication icon on top of it :slight_smile:

1 Like

Hmm…who would figure thAt out…test with another color background? Grey?